summaryrefslogtreecommitdiff
path: root/libv8/Makefile
diff options
context:
space:
mode:
authorIgor Pashev <igor.pashev@nexenta.com>2012-12-06 05:17:26 +0400
committerIgor Pashev <igor.pashev@nexenta.com>2012-12-06 05:17:26 +0400
commitfbbca5976a6e0b3db5aea626c25f06e5dceb531c (patch)
tree69d320c5818fe9df31fe0b5a3ace1b1c2bc1deff /libv8/Makefile
parent9c2569500d1536662eb2e2f0ea51b205398c2f4a (diff)
downloadcibs-pkgs-fbbca5976a6e0b3db5aea626c25f06e5dceb531c.tar.gz
Split libv8
Diffstat (limited to 'libv8/Makefile')
-rw-r--r--libv8/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/libv8/Makefile b/libv8/Makefile
index 8b5df93..44d199a 100644
--- a/libv8/Makefile
+++ b/libv8/Makefile
@@ -10,7 +10,8 @@ license := BSD
license-file := LICENSE.v8
version := 3.14.5
name := libv8
-libSoname := libv8.so
+libSoname := libv8.so.$(version)
+so-version := $(version)
build-depends += \
pkg:/developer/build/gyp
@@ -52,7 +53,7 @@ build-%-stamp: configure-%-stamp
CXX="$(CXX)" \
LINK="$(CXX)" \
library=shared \
- soname_version= \
+ soname_version=$(so-version) \
werror=no \
$(v8arch).release
touch $@