summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor Pashev <igor.pashev@nexenta.com>2012-12-06 05:17:26 +0400
committerIgor Pashev <igor.pashev@nexenta.com>2012-12-06 05:17:26 +0400
commitfbbca5976a6e0b3db5aea626c25f06e5dceb531c (patch)
tree69d320c5818fe9df31fe0b5a3ace1b1c2bc1deff
parent9c2569500d1536662eb2e2f0ea51b205398c2f4a (diff)
downloadcibs-pkgs-fbbca5976a6e0b3db5aea626c25f06e5dceb531c.tar.gz
Split libv8
-rw-r--r--libv8/Makefile5
-rw-r--r--libv8/libv8-so.p5m8
-rw-r--r--libv8/libv8.p5m8
3 files changed, 17 insertions, 4 deletions
diff --git a/libv8/Makefile b/libv8/Makefile
index 8b5df93..44d199a 100644
--- a/libv8/Makefile
+++ b/libv8/Makefile
@@ -10,7 +10,8 @@ license := BSD
license-file := LICENSE.v8
version := 3.14.5
name := libv8
-libSoname := libv8.so
+libSoname := libv8.so.$(version)
+so-version := $(version)
build-depends += \
pkg:/developer/build/gyp
@@ -52,7 +53,7 @@ build-%-stamp: configure-%-stamp
CXX="$(CXX)" \
LINK="$(CXX)" \
library=shared \
- soname_version= \
+ soname_version=$(so-version) \
werror=no \
$(v8arch).release
touch $@
diff --git a/libv8/libv8-so.p5m b/libv8/libv8-so.p5m
new file mode 100644
index 0000000..7ad6660
--- /dev/null
+++ b/libv8/libv8-so.p5m
@@ -0,0 +1,8 @@
+set name=pkg.fmri value=pkg:/library/$(name)-$(so-version)@$(ips-version)
+set name=pkg.summary value="$(summary), shared library, version $(so-version)"
+set name=info.upstream-url value="$(home)"
+set name=info.source-url value="$(download)"
+license $(license-file) license="$(license)"
+
+file path=usr/lib/$(mach64)/$(libSoname)
+
diff --git a/libv8/libv8.p5m b/libv8/libv8.p5m
index 3b078e9..b41bd39 100644
--- a/libv8/libv8.p5m
+++ b/libv8/libv8.p5m
@@ -1,10 +1,14 @@
set name=pkg.fmri value=pkg:/library/$(name)@$(ips-version)
-set name=pkg.summary value="$(summary), shared library, version $(so-version)"
+set name=pkg.summary value="$(summary)"
set name=info.upstream-url value="$(home)"
set name=info.source-url value="$(download)"
license $(license-file) license="$(license)"
-file path=usr/lib/$(mach64)/libv8.so
+depend fmri=pkg:/library/$(name)-$(so-version)@$(ips-version) type=require
+depend fmri=pkg:/library/$(name)-$(so-version)@$(ips-version) type=incorporate
+
+link path=usr/lib/$(mach64)/libv8.so \
+ target=$(libSoname)
file include/v8-debug.h path=usr/include/v8-debug.h
file include/v8-preparser.h path=usr/include/v8-preparser.h