summaryrefslogtreecommitdiff
path: root/libv8/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'libv8/Makefile')
-rw-r--r--libv8/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/libv8/Makefile b/libv8/Makefile
index 8b5df93..44d199a 100644
--- a/libv8/Makefile
+++ b/libv8/Makefile
@@ -10,7 +10,8 @@ license := BSD
license-file := LICENSE.v8
version := 3.14.5
name := libv8
-libSoname := libv8.so
+libSoname := libv8.so.$(version)
+so-version := $(version)
build-depends += \
pkg:/developer/build/gyp
@@ -52,7 +53,7 @@ build-%-stamp: configure-%-stamp
CXX="$(CXX)" \
LINK="$(CXX)" \
library=shared \
- soname_version= \
+ soname_version=$(so-version) \
werror=no \
$(v8arch).release
touch $@