summaryrefslogtreecommitdiff
path: root/libv8/Makefile
diff options
context:
space:
mode:
authorIgor Pashev <igor.pashev@nexenta.com>2012-11-07 17:51:12 +0400
committerIgor Pashev <igor.pashev@nexenta.com>2012-11-07 17:51:12 +0400
commit0082160622e6315f9c146d55b7c703dcbe01fc1b (patch)
tree50f01f1d6e8cbc91b5051b9e1de661c3184a7feb /libv8/Makefile
parenta0ce9a6f62da5bd77a17084123fd5db7acf3cd7e (diff)
downloadcibs-pkgs-0082160622e6315f9c146d55b7c703dcbe01fc1b.tar.gz
Unversioned libv8
Diffstat (limited to 'libv8/Makefile')
-rw-r--r--libv8/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/libv8/Makefile b/libv8/Makefile
index a526880..8b5df93 100644
--- a/libv8/Makefile
+++ b/libv8/Makefile
@@ -9,9 +9,8 @@ home := http://code.google.com/p/v8/
license := BSD
license-file := LICENSE.v8
version := 3.14.5
-so-version := $(version)
name := libv8
-libSoname := $(name).so.$(so-version)
+libSoname := libv8.so
build-depends += \
pkg:/developer/build/gyp
@@ -53,7 +52,7 @@ build-%-stamp: configure-%-stamp
CXX="$(CXX)" \
LINK="$(CXX)" \
library=shared \
- soname_version=$(so-version) \
+ soname_version= \
werror=no \
$(v8arch).release
touch $@