summaryrefslogtreecommitdiff
path: root/libv8
diff options
context:
space:
mode:
authorIgor Pashev <igor.pashev@nexenta.com>2012-11-07 17:51:12 +0400
committerIgor Pashev <igor.pashev@nexenta.com>2012-11-07 17:51:12 +0400
commit0082160622e6315f9c146d55b7c703dcbe01fc1b (patch)
tree50f01f1d6e8cbc91b5051b9e1de661c3184a7feb /libv8
parenta0ce9a6f62da5bd77a17084123fd5db7acf3cd7e (diff)
downloadcibs-pkgs-0082160622e6315f9c146d55b7c703dcbe01fc1b.tar.gz
Unversioned libv8
Diffstat (limited to 'libv8')
-rw-r--r--libv8/Makefile5
-rw-r--r--libv8/libv8-headers.p5m20
-rw-r--r--libv8/libv8.p5m10
3 files changed, 10 insertions, 25 deletions
diff --git a/libv8/Makefile b/libv8/Makefile
index a526880..8b5df93 100644
--- a/libv8/Makefile
+++ b/libv8/Makefile
@@ -9,9 +9,8 @@ home := http://code.google.com/p/v8/
license := BSD
license-file := LICENSE.v8
version := 3.14.5
-so-version := $(version)
name := libv8
-libSoname := $(name).so.$(so-version)
+libSoname := libv8.so
build-depends += \
pkg:/developer/build/gyp
@@ -53,7 +52,7 @@ build-%-stamp: configure-%-stamp
CXX="$(CXX)" \
LINK="$(CXX)" \
library=shared \
- soname_version=$(so-version) \
+ soname_version= \
werror=no \
$(v8arch).release
touch $@
diff --git a/libv8/libv8-headers.p5m b/libv8/libv8-headers.p5m
deleted file mode 100644
index 0c3fab8..0000000
--- a/libv8/libv8-headers.p5m
+++ /dev/null
@@ -1,20 +0,0 @@
-set name=pkg.fmri value=pkg:/library/$(name)-headers@$(ips-version)
-set name=pkg.summary value="$(summary), header files"
-set name=info.upstream-url value="$(home)"
-set name=info.source-url value="$(download)"
-license $(license-file) license="$(license)"
-
-depend fmri=pkg:/library/$(name)-$(so-version)@$(ips-version) type=require
-depend fmri=pkg:/library/$(name)-$(so-version)@$(ips-version) type=incorporate
-
-
-
-file include/v8-debug.h path=usr/include/v8-debug.h
-file include/v8-preparser.h path=usr/include/v8-preparser.h
-file include/v8-profiler.h path=usr/include/v8-profiler.h
-file include/v8-testing.h path=usr/include/v8-testing.h
-file include/v8.h path=usr/include/v8.h
-file include/v8stdint.h path=usr/include/v8stdint.h
-
-link path=usr/lib/$(mach64)/libv8.so target=libv8.so.$(so-version)
-
diff --git a/libv8/libv8.p5m b/libv8/libv8.p5m
index 788bb68..3b078e9 100644
--- a/libv8/libv8.p5m
+++ b/libv8/libv8.p5m
@@ -1,8 +1,14 @@
-set name=pkg.fmri value=pkg:/library/$(name)-$(so-version)@$(ips-version)
+set name=pkg.fmri value=pkg:/library/$(name)@$(ips-version)
set name=pkg.summary value="$(summary), shared library, version $(so-version)"
set name=info.upstream-url value="$(home)"
set name=info.source-url value="$(download)"
license $(license-file) license="$(license)"
-file path=usr/lib/$(mach64)/libv8.so.$(so-version)
+file path=usr/lib/$(mach64)/libv8.so
+file include/v8-debug.h path=usr/include/v8-debug.h
+file include/v8-preparser.h path=usr/include/v8-preparser.h
+file include/v8-profiler.h path=usr/include/v8-profiler.h
+file include/v8-testing.h path=usr/include/v8-testing.h
+file include/v8.h path=usr/include/v8.h
+file include/v8stdint.h path=usr/include/v8stdint.h