summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2013-06-28 01:40:03 +0400
committerIgor Pashev <pashev.igor@gmail.com>2013-06-28 01:41:11 +0400
commitf8d2e3cb74f472ed2223b4fc9090e92d48f27ee4 (patch)
tree496210f874c08b9a8dc4f5355c8531f558372ee2 /debian/rules
parent7aca7e847871e0d6f396bc3edf6452e111d762f5 (diff)
downloadopen-axiom-debian-f8d2e3cb74f472ed2223b4fc9090e92d48f27ee4.tar.gz
Use Clisp if SBCL is not available
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 8 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 5e3bb04..400d533 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,7 +12,15 @@ BUILD = $(CURDIR)/build-tree
LDFLAGS += -Wl,--as-needed
+# List of archs currently having SBCL
+# Keep build-deb on sbcl in one line: sbcl (...) [...],
+HAVE_SBCL := $(shell grep sbcl debian/control | sed -r 's,.*\[(.+)\].*,\1,')
+
+ifneq (,$(filter $(DEB_HOST_ARCH),$(HAVE_SBCL)))
LISP := sbcl
+else
+LISP := clisp
+endif
oa_libdir := /usr/lib/open-axiom