summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2013-06-28 01:40:03 +0400
committerIgor Pashev <pashev.igor@gmail.com>2013-06-28 01:41:11 +0400
commitf8d2e3cb74f472ed2223b4fc9090e92d48f27ee4 (patch)
tree496210f874c08b9a8dc4f5355c8531f558372ee2
parent7aca7e847871e0d6f396bc3edf6452e111d762f5 (diff)
downloadopen-axiom-debian-f8d2e3cb74f472ed2223b4fc9090e92d48f27ee4.tar.gz
Use Clisp if SBCL is not available
-rw-r--r--debian/changelog6
-rw-r--r--debian/control3
-rwxr-xr-xdebian/rules8
3 files changed, 13 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index cb8c525..e9a8e28 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-open-axiom (1.5.0~svn3038-1) unstable; urgency=low
+open-axiom (1.5.0~svn3039-1) unstable; urgency=low
* New upstream version.
* Use xz compression for both source tarball and packages
@@ -8,11 +8,11 @@ open-axiom (1.5.0~svn3038-1) unstable; urgency=low
requires aclocal 1.13
* Do not patch configure.ac, but override variables in Makefiles (due to
automake 1.13 too)
- * Only support SBCL, all other lisps cause FTBFS.
+ * Use Clisp if SBCL is not available (currently !i386 !amd64 !kfreebsd-amd64)
* Enable hardening (include /usr/share/dpkg/buildflags.mk for build flags)
* Use dh-buildinfo
- -- Igor Pashev <pashev.igor@gmail.com> Thu, 27 Jun 2013 12:05:47 +0400
+ -- Igor Pashev <pashev.igor@gmail.com> Fri, 28 Jun 2013 01:40:28 +0400
open-axiom (1.4.1+svn~2626-2) unstable; urgency=low
diff --git a/debian/control b/debian/control
index 9bd3bee..85b035a 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,8 @@ Priority: optional
Maintainer: Igor Pashev <pashev.igor@gmail.com>
Build-Depends:
debhelper ( >= 8 ),
- sbcl ( >= 1:1.0.30 ),
+ sbcl ( >= 1:1.0.30 ) [i386 amd64 kfreebsd-amd64],
+ clisp ( >= 1:2.44 ) [!i386 !amd64 !kfreebsd-amd64],
libxpm-dev,
libxt-dev,
g++ (>= 4.7),
diff --git a/debian/rules b/debian/rules
index 5e3bb04..400d533 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,7 +12,15 @@ BUILD = $(CURDIR)/build-tree
LDFLAGS += -Wl,--as-needed
+# List of archs currently having SBCL
+# Keep build-deb on sbcl in one line: sbcl (...) [...],
+HAVE_SBCL := $(shell grep sbcl debian/control | sed -r 's,.*\[(.+)\].*,\1,')
+
+ifneq (,$(filter $(DEB_HOST_ARCH),$(HAVE_SBCL)))
LISP := sbcl
+else
+LISP := clisp
+endif
oa_libdir := /usr/lib/open-axiom