summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 8 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 5e3bb04..400d533 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,7 +12,15 @@ BUILD = $(CURDIR)/build-tree
LDFLAGS += -Wl,--as-needed
+# List of archs currently having SBCL
+# Keep build-deb on sbcl in one line: sbcl (...) [...],
+HAVE_SBCL := $(shell grep sbcl debian/control | sed -r 's,.*\[(.+)\].*,\1,')
+
+ifneq (,$(filter $(DEB_HOST_ARCH),$(HAVE_SBCL)))
LISP := sbcl
+else
+LISP := clisp
+endif
oa_libdir := /usr/lib/open-axiom