summaryrefslogtreecommitdiff
path: root/sci-mathematics/open-axiom/open-axiom-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/open-axiom/open-axiom-9999.ebuild')
-rw-r--r--sci-mathematics/open-axiom/open-axiom-9999.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/sci-mathematics/open-axiom/open-axiom-9999.ebuild b/sci-mathematics/open-axiom/open-axiom-9999.ebuild
index 87a8383..f50903c 100644
--- a/sci-mathematics/open-axiom/open-axiom-9999.ebuild
+++ b/sci-mathematics/open-axiom/open-axiom-9999.ebuild
@@ -16,7 +16,15 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
LISPS=( sbcl clisp gcl ecls clozurecl )
CONF=( . . . ecl ccl )
-IUSE="${LISPS[*]} X threads"
+
+# The first lisp is default
+IUSE="X threads +${LISPS[0]}"
+n=${#LISPS[*]}
+for ((i=1; i < n; i++)); do
+ IUSE="$IUSE -${LISPS[$i]}"
+done
+
+
RDEPEND="X? ( x11-libs/libXpm
x11-libs/libXau