summaryrefslogtreecommitdiff
path: root/sci-mathematics/open-axiom/open-axiom-9999.ebuild
diff options
context:
space:
mode:
authorIgor <pashev.igor@gmail.com>2011-01-24 19:22:19 +0300
committerIgor <pashev.igor@gmail.com>2011-01-24 19:22:19 +0300
commitb7a5dbbe9d3a9049f0028cd9845e955cdbb739e5 (patch)
tree47ddfff9491005c445923ea121dd2424811a40ea /sci-mathematics/open-axiom/open-axiom-9999.ebuild
parentfcb672d2acfb80e26a4c4093c788d09617d9f1f8 (diff)
downloadebuilds-b7a5dbbe9d3a9049f0028cd9845e955cdbb739e5.tar.gz
SBCL is the default
Diffstat (limited to 'sci-mathematics/open-axiom/open-axiom-9999.ebuild')
-rw-r--r--sci-mathematics/open-axiom/open-axiom-9999.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/sci-mathematics/open-axiom/open-axiom-9999.ebuild b/sci-mathematics/open-axiom/open-axiom-9999.ebuild
index 87a8383..f50903c 100644
--- a/sci-mathematics/open-axiom/open-axiom-9999.ebuild
+++ b/sci-mathematics/open-axiom/open-axiom-9999.ebuild
@@ -16,7 +16,15 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
LISPS=( sbcl clisp gcl ecls clozurecl )
CONF=( . . . ecl ccl )
-IUSE="${LISPS[*]} X threads"
+
+# The first lisp is default
+IUSE="X threads +${LISPS[0]}"
+n=${#LISPS[*]}
+for ((i=1; i < n; i++)); do
+ IUSE="$IUSE -${LISPS[$i]}"
+done
+
+
RDEPEND="X? ( x11-libs/libXpm
x11-libs/libXau