summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor Pashev <igor.pashev@nexenta.com>2013-04-10 12:48:09 +0400
committerIgor Pashev <igor.pashev@nexenta.com>2013-04-10 12:48:09 +0400
commit17ea743083380fb333efeaddc194ca6cfc51668a (patch)
tree874d1d5da9ee0c05dd15f44470b31cca15010d72
parent53bcd105fb24ce794ec1f50da86e9cebe8b86b41 (diff)
downloadcibs-pkgs-17ea743083380fb333efeaddc194ca6cfc51668a.tar.gz
Dynamic libpython
-rw-r--r--python2.7/Makefile4
-rwxr-xr-x[-rw-r--r--]python2.7/libpython.p5m.gen (renamed from python2.7/libpython.p5m)20
2 files changed, 18 insertions, 6 deletions
diff --git a/python2.7/Makefile b/python2.7/Makefile
index 2a63529..2621607 100644
--- a/python2.7/Makefile
+++ b/python2.7/Makefile
@@ -181,13 +181,13 @@ postinst-stamp: install-default-stamp
$(movefiles) -s $(d) -d $(d_lib) \
usr/lib/libpython$(pyver).so.1.0 ; \
ln -sf libpython$(pyver).so.1.0 \
- $(d)/usr/lib/libpython$(pyver).so.1 ; \
+ $(d_lib)/usr/lib/libpython$(pyver).so.1 ; \
fi
if ls $(d)/usr/lib/$(mach64)/libpython$(pyver).so.* >/dev/null 2>&1; then \
$(movefiles) -s $(d) -d$(d_lib) \
usr/lib/$(mach64)/libpython$(pyver).so.1.0 ; \
ln -sf libpython$(pyver).so.1.0 \
- $(d)/usr/lib/$(mach64)/libpython$(pyver).so.1 ; \
+ $(d_lib)/usr/lib/$(mach64)/libpython$(pyver).so.1 ; \
fi
touch $@
diff --git a/python2.7/libpython.p5m b/python2.7/libpython.p5m.gen
index d468766..c724c34 100644..100755
--- a/python2.7/libpython.p5m
+++ b/python2.7/libpython.p5m.gen
@@ -1,3 +1,13 @@
+#!/bin/sh
+
+set -e
+set -u
+
+tmp=/tmp/cibs-python-minimal.$$
+
+proto=${proto:-work/proto/libpython}
+
+cat <<'META' > $tmp
set name=pkg.fmri value=pkg:/library/libpython$(pyver)@$(ips-version)
set name=pkg.summary value="Shared Python runtime library (version $(pyver))"
set name=info.upstream-url value="$(home)"
@@ -5,7 +15,9 @@ set name=info.source-url value="$(download)"
license $(license-file) license="$(license)"
-file path=usr/lib/$(mach64)/libpython$(pyver).so.1.0
-link path=usr/lib/$(mach64)/libpython$(pyver).so.1 target=libpython$(pyver).so.1.0
-link path=/usr/lib/python$(pyver)/config/libpython$(pyver).so \
- target=../../$(mach64)/libpython$(pyver).so.1
+META
+
+/usr/share/cibs/scripts/make-payload $proto >> $tmp
+cat $tmp
+rm $tmp
+