summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor Pashev <igor.pashev@nexenta.com>2013-04-10 12:25:33 +0400
committerIgor Pashev <igor.pashev@nexenta.com>2013-04-10 12:25:33 +0400
commit53bcd105fb24ce794ec1f50da86e9cebe8b86b41 (patch)
tree6a6a7f3e6f574e9182a30bfa7d2160499f8d6bed
parent3fd7c70391fef9a1593b25a808766c352239e958 (diff)
downloadcibs-pkgs-53bcd105fb24ce794ec1f50da86e9cebe8b86b41.tar.gz
Build depend on text/gawk; fix _sysconfigdata.py
-rw-r--r--python2.7/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/python2.7/Makefile b/python2.7/Makefile
index 1c0d5db..2a63529 100644
--- a/python2.7/Makefile
+++ b/python2.7/Makefile
@@ -30,6 +30,7 @@ checksum-Python-2.7.3.tar.bz2 := \
build-depends += \
compress/bzip2 \
+ developer/build/autoconf \
library/libbz2 \
library/libdb-5.1 \
library/libexpat \
@@ -40,8 +41,8 @@ build-depends += \
library/readline \
library/tinfo \
library/zlib \
+ text/gawk \
text/help2man \
- developer/build/autoconf
define __post_configure
egrep \
@@ -121,8 +122,9 @@ python-minimal.p5m: env += proto=$(d_min)
install-stamp: postinst-stamp
postinst-stamp: install-default-stamp
+ mv $(d)/$(scriptdir)/_sysconfigdata.py \
+ $(d)/$(scriptdir)/_sysconfigdata_nd.py
cp -p debian/_sysconfigdata.py $(d)/$(scriptdir)/
-
mv $(d)/usr/lib/python$(VER)/site-packages \
$(d)/usr/lib/python$(VER)/dist-packages
: # remove files, which are not packaged