aboutsummaryrefslogtreecommitdiff
path: root/pkgs/ldapply/main.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/ldapply/main.nix')
-rw-r--r--pkgs/ldapply/main.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/pkgs/ldapply/main.nix b/pkgs/ldapply/main.nix
new file mode 100644
index 0000000..3a69576
--- /dev/null
+++ b/pkgs/ldapply/main.nix
@@ -0,0 +1,16 @@
+{ mkDerivation, base, bytestring, docopt, interpolatedstring-perl6
+, LDAP, ldif, stdenv, unordered-containers
+}:
+mkDerivation {
+ pname = "ldapply";
+ version = "0.2.0";
+ sha256 = "0qgpb22k9krdhwjydzyfhjf85crxc49ss7x74mrqj8ivkzg5hl28";
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [
+ base bytestring docopt interpolatedstring-perl6 LDAP ldif
+ unordered-containers
+ ];
+ description = "LDIF idempotent apply tool";
+ license = stdenv.lib.licenses.mit;
+}