aboutsummaryrefslogtreecommitdiff
path: root/pkgs/ldapply/main.nix
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2018-12-11 18:10:48 +0300
committerIgor Pashev <pashev.igor@gmail.com>2018-12-11 18:10:48 +0300
commit8b0968b2054d3bb8d90b5ac056727f7c2ebeaed3 (patch)
treed03b70f693463fc836a8dbe4240424d2547530c8 /pkgs/ldapply/main.nix
parentc4273035cf5876e3ba8ed2c6b492d31c2de290ee (diff)
downloadnixsap-8b0968b2054d3bb8d90b5ac056727f7c2ebeaed3.tar.gz
(* HUGE *) Use nixpkgs overlays
Diffstat (limited to 'pkgs/ldapply/main.nix')
-rw-r--r--pkgs/ldapply/main.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/pkgs/ldapply/main.nix b/pkgs/ldapply/main.nix
new file mode 100644
index 0000000..3a69576
--- /dev/null
+++ b/pkgs/ldapply/main.nix
@@ -0,0 +1,16 @@
+{ mkDerivation, base, bytestring, docopt, interpolatedstring-perl6
+, LDAP, ldif, stdenv, unordered-containers
+}:
+mkDerivation {
+ pname = "ldapply";
+ version = "0.2.0";
+ sha256 = "0qgpb22k9krdhwjydzyfhjf85crxc49ss7x74mrqj8ivkzg5hl28";
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [
+ base bytestring docopt interpolatedstring-perl6 LDAP ldif
+ unordered-containers
+ ];
+ description = "LDIF idempotent apply tool";
+ license = stdenv.lib.licenses.mit;
+}