aboutsummaryrefslogtreecommitdiff
path: root/pkgs/ldapply/ldap.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/ldapply/ldap.nix')
-rw-r--r--pkgs/ldapply/ldap.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/pkgs/ldapply/ldap.nix b/pkgs/ldapply/ldap.nix
new file mode 100644
index 0000000..03a5fd3
--- /dev/null
+++ b/pkgs/ldapply/ldap.nix
@@ -0,0 +1,14 @@
+{ mkDerivation, base, HUnit, cyrus_sasl, openldap, stdenv }:
+mkDerivation {
+ pname = "LDAP";
+ version = "0.6.11";
+ doCheck = false; # XXX: missing file in tarball
+ sha256 = "1cwh3272zi5r0zznmixghf87vskz7s35bmz6ifyky0xk3s04ijq1";
+ libraryHaskellDepends = [ base ];
+ librarySystemDepends = [ cyrus_sasl openldap ];
+ testHaskellDepends = [ base HUnit ];
+ testSystemDepends = [ openldap ];
+ homepage = "https://github.com/ezyang/ldap-haskell";
+ description = "Haskell binding for C LDAP API";
+ license = stdenv.lib.licenses.bsd3;
+}