aboutsummaryrefslogtreecommitdiff
path: root/pkgs/ldapply/ldap.nix
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2018-12-11 18:10:48 +0300
committerIgor Pashev <pashev.igor@gmail.com>2018-12-11 18:10:48 +0300
commit8b0968b2054d3bb8d90b5ac056727f7c2ebeaed3 (patch)
treed03b70f693463fc836a8dbe4240424d2547530c8 /pkgs/ldapply/ldap.nix
parentc4273035cf5876e3ba8ed2c6b492d31c2de290ee (diff)
downloadnixsap-8b0968b2054d3bb8d90b5ac056727f7c2ebeaed3.tar.gz
(* HUGE *) Use nixpkgs overlays
Diffstat (limited to 'pkgs/ldapply/ldap.nix')
-rw-r--r--pkgs/ldapply/ldap.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/pkgs/ldapply/ldap.nix b/pkgs/ldapply/ldap.nix
new file mode 100644
index 0000000..03a5fd3
--- /dev/null
+++ b/pkgs/ldapply/ldap.nix
@@ -0,0 +1,14 @@
+{ mkDerivation, base, HUnit, cyrus_sasl, openldap, stdenv }:
+mkDerivation {
+ pname = "LDAP";
+ version = "0.6.11";
+ doCheck = false; # XXX: missing file in tarball
+ sha256 = "1cwh3272zi5r0zznmixghf87vskz7s35bmz6ifyky0xk3s04ijq1";
+ libraryHaskellDepends = [ base ];
+ librarySystemDepends = [ cyrus_sasl openldap ];
+ testHaskellDepends = [ base HUnit ];
+ testSystemDepends = [ openldap ];
+ homepage = "https://github.com/ezyang/ldap-haskell";
+ description = "Haskell binding for C LDAP API";
+ license = stdenv.lib.licenses.bsd3;
+}