aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authordos-reis <gdr@axiomatics.org>2011-08-24 03:17:31 +0000
committerdos-reis <gdr@axiomatics.org>2011-08-24 03:17:31 +0000
commitffbca7d35e4541017c1e1d736dacbe27e0de2c21 (patch)
tree6472437711d170ee121540af466b96ed57caab53 /Makefile.am
parentd7d39823cf29e2b981e20fee3b0454624897371d (diff)
downloadopen-axiom-ffbca7d35e4541017c1e1d736dacbe27e0de2c21.tar.gz
* algebra/Makefile.in: Support construction initial DB profile.
* interp/database.boot (printInitdbInfo): New. (printAllInitdbInfo): Likewise. * interp/sys-driver.boot (initializeDatabases): Exit early if constructing initial DB profile. (buildInitdbHandler): New. Handle --build-initdb. * utils/command.cc (driver_table): Add map for --build-initdb.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 1 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index d20715f3..6c1a79cf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -56,6 +56,7 @@ OA_SRC_TARGETS = \
all-src \
all-algebra \
all-algstrap \
+ all-initdb \
all-asq \
all-axiomsys \
all-boot \
@@ -85,10 +86,6 @@ all: all-local
$(OA_SRC_TARGETS):
cd src && $(MAKE) $@
-.PHONY: all-algstrap
-all-algstrap: all-interpsys
- cd src/algebra && $(MAKE) $@
-
.PHONY: all-gcl
all-gcl: $(oa_builddir)/bin/gcl$(EXEEXT)