aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authordos-reis <gdr@axiomatics.org>2011-08-23 22:11:26 +0000
committerdos-reis <gdr@axiomatics.org>2011-08-23 22:11:26 +0000
commitd7d39823cf29e2b981e20fee3b0454624897371d (patch)
tree93ec151376babb45ce72a63d698e798c2c14da95 /Makefile.am
parent0416c1e54eb6a6209f17a32d163328f6bae5f595 (diff)
downloadopen-axiom-d7d39823cf29e2b981e20fee3b0454624897371d.tar.gz
* interp/sys-driver.boot (initializeDatabases): New.
(initializeGlobalState): Use it. * interp/spad-parser.boot (parseSpadFile): Tidy. * interp/g-cndata.boot (installConstructor): Exit early it global table not initialized. * interp/database.boot (makeInitialDB): New. (populateDBFromFile): Likewise. * interp/daase.lisp: Introduce more DB accessors. * interp/br-util.boot (dbSourceFile): Remove. * interp/br-con.boot (kdPageInfo): Use getConstructorSourceFileFromDB instead of dbSourceFile. (kPage): Likewise. * algebra/Makefile.in (SPADFILES): Include domain.spad
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 191f6deb..d20715f3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -55,6 +55,7 @@ OA_SRC_TARGETS = \
all-local \
all-src \
all-algebra \
+ all-algstrap \
all-asq \
all-axiomsys \
all-boot \
@@ -77,7 +78,7 @@ OA_SRC_TARGETS = \
if OA_BUILD_GCL
all-recursive all-boot all-lisp all-interpsys all-axiomsys \
- all-algebra all-input all-src all-local: all-gcl
+ all-algebra all-algstrap all-input all-src all-local: all-gcl
endif
all: all-local
@@ -85,7 +86,7 @@ $(OA_SRC_TARGETS):
cd src && $(MAKE) $@
.PHONY: all-algstrap
-all-algstrap:
+all-algstrap: all-interpsys
cd src/algebra && $(MAKE) $@
.PHONY: all-gcl