aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authordos-reis <gdr@axiomatics.org>2010-11-26 22:07:40 +0000
committerdos-reis <gdr@axiomatics.org>2010-11-26 22:07:40 +0000
commitded1d9f1137b1f747eb62de938f14ad7eff82036 (patch)
tree6ba5b6ca872c9c9d110249d0d52bfd8bdf02493e /Makefile.am
parent79add112a71e07b63e62e3b52f4759de243b00a1 (diff)
downloadopen-axiom-ded1d9f1137b1f747eb62de938f14ad7eff82036.tar.gz
Fix from previous commit
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am24
1 files changed, 10 insertions, 14 deletions
diff --git a/Makefile.am b/Makefile.am
index 3e2ddbc5..f97fc512 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -45,6 +45,9 @@ ACLOCAL_AMFLAGS = -I config --install --output=config/aclocal.m4
SUBDIRS = @oa_gcldir@ src
+oa_builddir = $(abs_top_builddir)/build/$(target)
+oa_installdir = @open_axiom_installdir@
+
# Configure options to GCL.
GCLOPTS=@GCLOPTS@
@@ -70,8 +73,7 @@ OA_SRC_TARGETS = \
.PHONY: all-oa $(OA_SRC_TARGETS)
-$(OA_SRC_TARGETS): stamp-rootdirs
-all-src: stamp-rootdirs @oa_all_prerequisites@
+all-src: @oa_all_prerequisites@
if OA_BUILD_GCL
all-recursive all-boot all-lisp all-interpsys all-axiomsys \
@@ -85,24 +87,20 @@ $(OA_SRC_TARGETS):
all-algstrap:
cd src/algebra && $(MAKE) $@
-stamp-rootdirs:
- @$(STAMP) stamp-rootdirs
-
-
.PHONY: all-gcl
-all-gcl: $(axiom_build_bindir)/gcl$(EXEEXT)
+all-gcl: $(oa_builddir)/bin/gcl$(EXEEXT)
-$(axiom_build_bindir)/gcl$(EXEEXT):
+$(oa_builddir)/bin/gcl$(EXEEXT):
if test "$(srcdir)" != "$(builddir)" -a ! -d gcl; then \
cp -r "$(srcdir)"/gcl "$(builddir)"; \
fi; cd gcl; \
- ./configure --prefix="$(axiom_abs_builddir)" ${GCLOPTS} && \
+ ./configure --prefix="$(oa_builddir)" ${GCLOPTS} && \
$(MAKE) && $(MAKE) install
install-exec-local:
@echo Installing OpenAxiom in $(DESTDIR)$(prefix)
- @$(mkinstalldirs) "$(DESTDIR)$(open_axiom_installdir)"
- cp -pr "$(builddir)"/$(target)/* "$(DESTDIR)$(open_axiom_installdir)"
+ @$(mkinstalldirs) "$(DESTDIR)$(oa_installdir)"
+ cp -pr "$(builddir)"/$(target)/* "$(DESTDIR)$(oa_installdir)"
rm -f "$(DESTDIR)$(bindir)"/open-axiom
@$(mkinstalldirs) "$(DESTDIR)$(bindir)"
$(INSTALL_PROGRAM) src/driver/open-axiom$(EXEEXT) "$(DESTDIR)$(bindir)"
@@ -112,8 +110,6 @@ install-exec-local:
check:
cd src && $(MAKE) all-check
-
clean-local:
- @-rm -rf "$(axiom_targetdir)"
+ @-rm -rf $(target)
@-rm -rf build
- @-rm -f stamp-*