aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authordos-reis <gdr@axiomatics.org>2010-11-26 20:30:28 +0000
committerdos-reis <gdr@axiomatics.org>2010-11-26 20:30:28 +0000
commit79add112a71e07b63e62e3b52f4759de243b00a1 (patch)
tree306ae6c923c2e7785bd1ef551e8bf29708668604 /Makefile.am
parenta6eaf7f6bc93fd8d5629332f3c138616914e6b94 (diff)
downloadopen-axiom-79add112a71e07b63e62e3b52f4759de243b00a1.tar.gz
* Makefile.am: New. Automake existing top-level Makefile.in.
* Makefile.in: Generate from Makefile.am. * config/aclocal.m4: Regenerate.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am119
1 files changed, 119 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 00000000..3e2ddbc5
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,119 @@
+# Copyright (C) 2010, Gabriel Dos Reis.
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
+#
+# - Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# - Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in
+# the documentation and/or other materials provided with the
+# distribution.
+#
+# - Neither the name of The Numerical Algorithms Group Ltd. nor the
+# names of its contributors may be used to endorse or promote products
+# derived from this software without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS
+# IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED
+# TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
+# PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER
+# OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
+# EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
+# PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
+# LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
+# NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+
+# The build system is set up so that if `make all' completes successfully
+# then `make install' will not modify any file in the build directory.
+# Consequently it is possible to issue `make all' as an one user
+# to build the whole system, and install it as another user. The typical
+# case is: on Unix-like system, build as ordinary user, then install as
+# superuser.
+
+# The build flow of OpenAxiom seems, at first sight, a bit intricate to
+# describe. This description is STILL IN WORK IN PROGRESS. Therefore
+# it is incorrekt, incomplet, and iNconSiStenT.
+
+ACLOCAL_AMFLAGS = -I config --install --output=config/aclocal.m4
+
+SUBDIRS = @oa_gcldir@ src
+
+# Configure options to GCL.
+GCLOPTS=@GCLOPTS@
+
+OA_SRC_TARGETS = \
+ all-algebra \
+ all-asq \
+ all-axiomsys \
+ all-boot \
+ all-share \
+ all-clef \
+ all-doc \
+ all-graph \
+ all-hyper \
+ all-input \
+ all-interpsys \
+ all-lib \
+ all-lisp \
+ all-sman \
+ all-driver \
+ all-src \
+ all-databases \
+ all-utils
+
+.PHONY: all-oa $(OA_SRC_TARGETS)
+
+$(OA_SRC_TARGETS): stamp-rootdirs
+all-src: stamp-rootdirs @oa_all_prerequisites@
+
+if OA_BUILD_GCL
+all-recursive all-boot all-lisp all-interpsys all-axiomsys \
+ all-algebra all-input: all-gcl
+endif
+
+$(OA_SRC_TARGETS):
+ cd src && $(MAKE) $@
+
+.PHONY: all-algstrap
+all-algstrap:
+ cd src/algebra && $(MAKE) $@
+
+stamp-rootdirs:
+ @$(STAMP) stamp-rootdirs
+
+
+.PHONY: all-gcl
+all-gcl: $(axiom_build_bindir)/gcl$(EXEEXT)
+
+$(axiom_build_bindir)/gcl$(EXEEXT):
+ if test "$(srcdir)" != "$(builddir)" -a ! -d gcl; then \
+ cp -r "$(srcdir)"/gcl "$(builddir)"; \
+ fi; cd gcl; \
+ ./configure --prefix="$(axiom_abs_builddir)" ${GCLOPTS} && \
+ $(MAKE) && $(MAKE) install
+
+install-exec-local:
+ @echo Installing OpenAxiom in $(DESTDIR)$(prefix)
+ @$(mkinstalldirs) "$(DESTDIR)$(open_axiom_installdir)"
+ cp -pr "$(builddir)"/$(target)/* "$(DESTDIR)$(open_axiom_installdir)"
+ rm -f "$(DESTDIR)$(bindir)"/open-axiom
+ @$(mkinstalldirs) "$(DESTDIR)$(bindir)"
+ $(INSTALL_PROGRAM) src/driver/open-axiom$(EXEEXT) "$(DESTDIR)$(bindir)"
+ @echo OpenAxiom installation finished.
+
+.PHONY: check
+check:
+ cd src && $(MAKE) all-check
+
+
+clean-local:
+ @-rm -rf "$(axiom_targetdir)"
+ @-rm -rf build
+ @-rm -f stamp-*