aboutsummaryrefslogtreecommitdiff
path: root/modules/apps/filebackup.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/apps/filebackup.nix')
-rw-r--r--modules/apps/filebackup.nix6
1 files changed, 2 insertions, 4 deletions
diff --git a/modules/apps/filebackup.nix b/modules/apps/filebackup.nix
index 4aee0a9..ec3d84d 100644
--- a/modules/apps/filebackup.nix
+++ b/modules/apps/filebackup.nix
@@ -4,7 +4,7 @@ let
inherit (builtins)
isBool isList isString toString ;
inherit (lib)
- concatMapStringsSep concatStringsSep filter filterAttrs
+ concatMapStringsSep concatStringsSep filterAttrs
flatten hasPrefix mapAttrsToList mkIf
mkOption optionalString removeSuffix ;
inherit (lib.types)
@@ -203,8 +203,6 @@ let
exit "$failed"
'';
- keys = filter (f: f != null && hasPrefix "/run/keys/" f) ( [cfg.s3cfg] );
-
in {
options.nixsap.apps.filebackup = {
user = mkOption {
@@ -265,7 +263,7 @@ in {
config = mkIf (cfg.files != {}) {
nixsap.system.users.daemons = [ cfg.user ];
- nixsap.deployment.keyrings.${cfg.user} = keys;
+ nixsap.deployment.keyrings.${cfg.user} = [ cfg.s3cfg ];
systemd.services.filebackup = {
description = "Directory backup with tar";
after = [ "local-fs.target" "keys.target" ];