aboutsummaryrefslogtreecommitdiff
path: root/modules/apps/filebackup.nix
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2016-10-13 16:21:52 +0300
committerIgor Pashev <pashev.igor@gmail.com>2016-10-13 16:27:34 +0300
commitb40e89f23632d3fabe95bbf214bb77a32567b3d9 (patch)
treea76f8222e93152f3886008ad6ef7b6eadbe401ba /modules/apps/filebackup.nix
parentb24ae5d345aa84bdba20efbb4a14ddfc9bf39873 (diff)
downloadnixsap-b40e89f23632d3fabe95bbf214bb77a32567b3d9.tar.gz
Do not filter keys at application level
It's done in the nixsap.deployment module See b24ae5d345aa84bdba20efbb4a14ddfc9bf39873
Diffstat (limited to 'modules/apps/filebackup.nix')
-rw-r--r--modules/apps/filebackup.nix6
1 files changed, 2 insertions, 4 deletions
diff --git a/modules/apps/filebackup.nix b/modules/apps/filebackup.nix
index 4aee0a9..ec3d84d 100644
--- a/modules/apps/filebackup.nix
+++ b/modules/apps/filebackup.nix
@@ -4,7 +4,7 @@ let
inherit (builtins)
isBool isList isString toString ;
inherit (lib)
- concatMapStringsSep concatStringsSep filter filterAttrs
+ concatMapStringsSep concatStringsSep filterAttrs
flatten hasPrefix mapAttrsToList mkIf
mkOption optionalString removeSuffix ;
inherit (lib.types)
@@ -203,8 +203,6 @@ let
exit "$failed"
'';
- keys = filter (f: f != null && hasPrefix "/run/keys/" f) ( [cfg.s3cfg] );
-
in {
options.nixsap.apps.filebackup = {
user = mkOption {
@@ -265,7 +263,7 @@ in {
config = mkIf (cfg.files != {}) {
nixsap.system.users.daemons = [ cfg.user ];
- nixsap.deployment.keyrings.${cfg.user} = keys;
+ nixsap.deployment.keyrings.${cfg.user} = [ cfg.s3cfg ];
systemd.services.filebackup = {
description = "Directory backup with tar";
after = [ "local-fs.target" "keys.target" ];