summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xdebian/rules15
1 files changed, 14 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 698a075..26b0d3e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -24,7 +24,7 @@ debian/open-axiom.1:
# make clean does not clean properly
# so building out of source
-BUILD = build-tree
+BUILD = $(CURDIR)/build-tree
LDFLAGS = -Wl,--as-needed
@@ -34,6 +34,19 @@ override_dh_auto_configure:
--with-x \
LDFLAGS="$(LDFLAGS)"
+# Remove shebangs and "compiled from ..." lines.
+# This makes lintian happy and prevents disclosure
+# of paths on build machine. E. g.:
+## !$(BUILD)/src/interp/interpsys --script
+## FASL
+# compiled from "$(BUILD)/src/algebra/IDECOMP.NRLIB/code.lsp"
+# using SBCL version 1.0.50.0.debian
+#
+override_dh_auto_install:
+ dh_auto_install
+ find debian/tmp -type f -name \*.fasl -exec \
+ sed -i '/^#!/ d; /compiled/ d' {} \;
+
override_dh_auto_clean:
rm -rf $(BUILD)