summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2011-08-28 22:54:55 +0400
committerIgor Pashev <pashev.igor@gmail.com>2011-08-28 22:54:55 +0400
commit01fa81848f30e324c509f23eb3f6b6c669cc24d9 (patch)
tree4087f0db19abc1db5cf99a3ff92caa85cdf774d6
parent43ad9fa84b9667ecbc48a5ab8915a80909ab2f2e (diff)
downloadopen-axiom-debian-01fa81848f30e324c509f23eb3f6b6c669cc24d9.tar.gz
Remove shebangs and "compiled from ..." lines from FASL-files
-rwxr-xr-xdebian/rules15
1 files changed, 14 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 698a075..26b0d3e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -24,7 +24,7 @@ debian/open-axiom.1:
# make clean does not clean properly
# so building out of source
-BUILD = build-tree
+BUILD = $(CURDIR)/build-tree
LDFLAGS = -Wl,--as-needed
@@ -34,6 +34,19 @@ override_dh_auto_configure:
--with-x \
LDFLAGS="$(LDFLAGS)"
+# Remove shebangs and "compiled from ..." lines.
+# This makes lintian happy and prevents disclosure
+# of paths on build machine. E. g.:
+## !$(BUILD)/src/interp/interpsys --script
+## FASL
+# compiled from "$(BUILD)/src/algebra/IDECOMP.NRLIB/code.lsp"
+# using SBCL version 1.0.50.0.debian
+#
+override_dh_auto_install:
+ dh_auto_install
+ find debian/tmp -type f -name \*.fasl -exec \
+ sed -i '/^#!/ d; /compiled/ d' {} \;
+
override_dh_auto_clean:
rm -rf $(BUILD)