summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2011-11-13 00:38:11 +0400
committerIgor Pashev <pashev.igor@gmail.com>2011-11-13 00:38:11 +0400
commit076e69430258b8a59d06a581981eafa34b0298dd (patch)
tree5ae22a5dc6fa9897009cb84402b63ca79ba30ec2 /debian/rules
parentddceec70e3323543af6137c4ccb24a395bc62be0 (diff)
downloadopen-axiom-debian-076e69430258b8a59d06a581981eafa34b0298dd.tar.gz
New upstream version (SVN). Use SBCL where available and CLISP otherwheres; removed patch for system xpm.h
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules14
1 files changed, 11 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 830ece1..7c2e388 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,15 @@
#!/usr/bin/make -f
+DEB_HOST_ARCH := $(shell dpkg-architecture -qDEB_HOST_ARCH)
+
+# List of archs currently having SBCL
+ifneq ($(filter $(DEB_HOST_ARCH), i386 amd64 freebsd-amd64),)
+LISP := sbcl
+else
+LISP := clisp
+endif
+
+
PACKAGE = open-axiom
SVN_REPO = https://open-axiom.svn.sf.net/svnroot/open-axiom/trunk
SRC_VERSION := $(shell dpkg-parsechangelog | sed -ne 's/^Version: \(\([0-9]\+\):\)\?\(.*\)-.*/\3/p')
@@ -13,8 +23,6 @@ get-orig-source:
get-orig-source/$(PACKAGE)-$(SRC_VERSION).orig
GZIP='--best --no-name' \
tar czf $(TARBALL) -C get-orig-source \
- --exclude contrib \
- --exclude src/include/xpm.h \
$(PACKAGE)-$(SRC_VERSION).orig
rm -rf get-orig-source
echo " "$(TARBALL)" created; move it to the right destination to build the package"
@@ -34,7 +42,7 @@ LDFLAGS = -Wl,--as-needed
override_dh_auto_configure:
dh_auto_configure -B $(BUILD) -- \
- --with-lisp=sbcl \
+ --with-lisp=$(LISP) \
--with-x \
LDFLAGS="$(LDFLAGS)"