summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2011-11-13 00:38:11 +0400
committerIgor Pashev <pashev.igor@gmail.com>2011-11-13 00:38:11 +0400
commit076e69430258b8a59d06a581981eafa34b0298dd (patch)
tree5ae22a5dc6fa9897009cb84402b63ca79ba30ec2
parentddceec70e3323543af6137c4ccb24a395bc62be0 (diff)
downloadopen-axiom-debian-076e69430258b8a59d06a581981eafa34b0298dd.tar.gz
New upstream version (SVN). Use SBCL where available and CLISP otherwheres; removed patch for system xpm.h
-rw-r--r--debian/README.source7
-rw-r--r--debian/changelog10
-rw-r--r--debian/control3
-rw-r--r--debian/patches/series1
-rw-r--r--debian/patches/use-system-xpm.h.patch13
-rwxr-xr-xdebian/rules14
6 files changed, 23 insertions, 25 deletions
diff --git a/debian/README.source b/debian/README.source
index 6eb9be4..fa413fa 100644
--- a/debian/README.source
+++ b/debian/README.source
@@ -4,10 +4,3 @@ source tarball for OpenAxiom: get-orig-source.
It fetches sources from SVN repository on SourceForge,
the SVN revision should be specified in version in "debian/changelog".
-
-For the first release (1.4.1+svn~2299+ds-1) these files are removed
-from original tarball (that's why +ds):
-
-./contrib (due to lisences mess)
-./src/include/xpm.h (system header is used;
- this file will be removed in upstream too)
diff --git a/debian/changelog b/debian/changelog
index b5074c5..113936a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+open-axiom (1.4.1+svn~2463-1) unstable; urgency=low
+
+ * New upstream version
+ * Include directory 'contrib' in sources
+ * Removed patch for system xpm.h (fixed in upstream)
+ * Use SBCL where available (currently i386, amd64, freebsd-amd64)
+ and CLISP otherwheres
+
+ -- Igor Pashev <pashev.igor@gmail.com> Sun, 13 Nov 2011 00:32:54 +0400
+
open-axiom (1.4.1+svn~2299+ds-1) unstable; urgency=low
* Initial release. Closes: #639185
diff --git a/debian/control b/debian/control
index b3a3766..6a57c9c 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,8 @@ Priority: optional
Maintainer: Igor Pashev <pashev.igor@gmail.com>
Build-Depends:
debhelper ( >= 8 ),
- sbcl ( >= 1:1.0.30 ),
+ sbcl ( >= 1:1.0.30 ) [i386, amd64, freebsd-amd64],
+ clisp ( >= 2.44 ) [!i386, !amd64, !freebsd-amd64],
libxpm-dev,
libxt-dev,
help2man,
diff --git a/debian/patches/series b/debian/patches/series
index ec5bee6..b38a365 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,4 +1,3 @@
install-dir.patch
no-missing-messages.patch
non-static-open-axiom-binary.patch
-use-system-xpm.h.patch
diff --git a/debian/patches/use-system-xpm.h.patch b/debian/patches/use-system-xpm.h.patch
deleted file mode 100644
index 801ef5c..0000000
--- a/debian/patches/use-system-xpm.h.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: open-axiom-debian/src/lib/pixmap.c
-===================================================================
---- open-axiom-debian.orig/src/lib/pixmap.c 2011-09-03 03:05:32.000000000 +0400
-+++ open-axiom-debian/src/lib/pixmap.c 2011-09-03 03:55:34.000000000 +0400
-@@ -263,7 +263,7 @@
- #else /*OLD*/
-
-
--#include "xpm.h"
-+#include <X11/xpm.h>
-
- int
- read_pixmap_file(Display *display, int screen, char *filename,
diff --git a/debian/rules b/debian/rules
index 830ece1..7c2e388 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,15 @@
#!/usr/bin/make -f
+DEB_HOST_ARCH := $(shell dpkg-architecture -qDEB_HOST_ARCH)
+
+# List of archs currently having SBCL
+ifneq ($(filter $(DEB_HOST_ARCH), i386 amd64 freebsd-amd64),)
+LISP := sbcl
+else
+LISP := clisp
+endif
+
+
PACKAGE = open-axiom
SVN_REPO = https://open-axiom.svn.sf.net/svnroot/open-axiom/trunk
SRC_VERSION := $(shell dpkg-parsechangelog | sed -ne 's/^Version: \(\([0-9]\+\):\)\?\(.*\)-.*/\3/p')
@@ -13,8 +23,6 @@ get-orig-source:
get-orig-source/$(PACKAGE)-$(SRC_VERSION).orig
GZIP='--best --no-name' \
tar czf $(TARBALL) -C get-orig-source \
- --exclude contrib \
- --exclude src/include/xpm.h \
$(PACKAGE)-$(SRC_VERSION).orig
rm -rf get-orig-source
echo " "$(TARBALL)" created; move it to the right destination to build the package"
@@ -34,7 +42,7 @@ LDFLAGS = -Wl,--as-needed
override_dh_auto_configure:
dh_auto_configure -B $(BUILD) -- \
- --with-lisp=sbcl \
+ --with-lisp=$(LISP) \
--with-x \
LDFLAGS="$(LDFLAGS)"