summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2011-08-28 03:13:28 +0400
committerIgor Pashev <pashev.igor@gmail.com>2011-08-28 03:13:28 +0400
commitab060738c5dd40b693bb7c3b3a2b52f553618ea6 (patch)
tree39455a18089c0f27eb16ce197c45433943f6375a
parenta2e39b28700de5732afe513b60d3081a09c704b9 (diff)
downloadopen-axiom-debian-ab060738c5dd40b693bb7c3b3a2b52f553618ea6.tar.gz
Generate man page with help2man
-rw-r--r--debian/clean1
-rw-r--r--debian/control1
-rw-r--r--debian/open-axiom.14
-rwxr-xr-xdebian/rules39
4 files changed, 29 insertions, 16 deletions
diff --git a/debian/clean b/debian/clean
new file mode 100644
index 0000000..2197053
--- /dev/null
+++ b/debian/clean
@@ -0,0 +1 @@
+debian/open-axiom.1
diff --git a/debian/control b/debian/control
index ae34905..02e0f78 100644
--- a/debian/control
+++ b/debian/control
@@ -6,6 +6,7 @@ Build-Depends:
debhelper ( >= 8 ),
sbcl ( >= 1.0.30 ),
libxpm-dev,
+ help2man,
#TODO: OA has some gui, need to know more
# libqt4-dev ( >= 4.6 ),
Standards-Version: 3.9.2
diff --git a/debian/open-axiom.1 b/debian/open-axiom.1
index 5a6f718..4559a40 100644
--- a/debian/open-axiom.1
+++ b/debian/open-axiom.1
@@ -1,7 +1,7 @@
.\" DO NOT MODIFY THIS FILE! It was generated by help2man 1.40.4.
-.TH OPENAXIOM "1" "August 2011" "OpenAxiom 1.5.0-2011-07-07" "The open scientific computation platform"
+.TH OPEN-AXIOM "1" "August 2011" "open-axiom 1.4.1+svn~2299" "The open scientific computation platform"
.SH NAME
-OpenAxiom \- open source platform for symbolic, algebraic, and numerical computations. It offers an interactive environment, an expressive programming language, a compiler, a large set of mathematical libraries of interest to researchers and practitioners of computational sciences
+open-axiom \- open source platform for symbolic, algebraic, and numerical computations
.SH SYNOPSIS
.B open-axiom
[\fIoptions\fR] [\fIfile\fR]
diff --git a/debian/rules b/debian/rules
index ed31202..698a075 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,27 @@
#!/usr/bin/make -f
+PACKAGE = open-axiom
+SVN_REPO = https://open-axiom.svn.sf.net/svnroot/open-axiom/trunk
+SRC_VERSION := $(shell dpkg-parsechangelog | sed -ne 's/^Version: \(\([0-9]\+\):\)\?\(.*\)-.*/\3/p')
+SVN_REVISION := $(shell echo $(SRC_VERSION) | awk -F"+" '{ print $$2 }' | sed 's/svn~//' )
+TARBALL = $(PACKAGE)_$(SRC_VERSION).orig.tar.gz
+.PHONY: get-orig-source
+get-orig-source:
+ rm -rf get-orig-source $(TARBALL)
+ mkdir get-orig-source
+ svn export -r $(SVN_REVISION) $(SVN_REPO) \
+ get-orig-source/$(PACKAGE)-$(SRC_VERSION).orig
+ GZIP='--best --no-name' tar czf $(TARBALL) -C get-orig-source $(PACKAGE)-$(SRC_VERSION).orig
+ rm -rf get-orig-source
+ echo " "$(TARBALL)" created; move it to the right destination to build the package"
+
+debian/open-axiom.1:
+ help2man --no-info \
+ --version-string='$(SRC_VERSION)' \
+ -m 'The open scientific computation platform' \
+ -n 'open source platform for symbolic, algebraic, and numerical computations' \
+ $(BUILD)/src/driver/open-axiom > $@
+
# make clean does not clean properly
# so building out of source
BUILD = build-tree
@@ -18,6 +40,9 @@ override_dh_auto_clean:
override_dh_install:
dh_install --list-missing
+override_dh_installman: debian/open-axiom.1
+ dh_installman
+
# AXIOMsys seems already stripped,
# and dh_strip breaks it
override_dh_strip:
@@ -32,17 +57,3 @@ override_dh_installdocs:
clean build install binary binary-arch binary-indep:
dh $@ --builddir=$(BUILD)
-PACKAGE = open-axiom
-SVN_REPO = https://open-axiom.svn.sf.net/svnroot/open-axiom/trunk
-SRC_VERSION := $(shell dpkg-parsechangelog | sed -ne 's/^Version: \(\([0-9]\+\):\)\?\(.*\)-.*/\3/p')
-SVN_REVISION := $(shell echo $(SRC_VERSION) | awk -F"+" '{ print $$2 }' | sed 's/svn~//' )
-TARBALL = $(PACKAGE)_$(SRC_VERSION).orig.tar.gz
-.PHONY: get-orig-source
-get-orig-source:
- rm -rf get-orig-source $(TARBALL)
- mkdir get-orig-source
- svn export -r $(SVN_REVISION) $(SVN_REPO) \
- get-orig-source/$(PACKAGE)-$(SRC_VERSION).orig
- GZIP='--best --no-name' tar czf $(TARBALL) -C get-orig-source $(PACKAGE)-$(SRC_VERSION).orig
- rm -rf get-orig-source
- echo " "$(TARBALL)" created; move it to the right destination to build the package"