summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules39
1 files changed, 25 insertions, 14 deletions
diff --git a/debian/rules b/debian/rules
index ed31202..698a075 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,27 @@
#!/usr/bin/make -f
+PACKAGE = open-axiom
+SVN_REPO = https://open-axiom.svn.sf.net/svnroot/open-axiom/trunk
+SRC_VERSION := $(shell dpkg-parsechangelog | sed -ne 's/^Version: \(\([0-9]\+\):\)\?\(.*\)-.*/\3/p')
+SVN_REVISION := $(shell echo $(SRC_VERSION) | awk -F"+" '{ print $$2 }' | sed 's/svn~//' )
+TARBALL = $(PACKAGE)_$(SRC_VERSION).orig.tar.gz
+.PHONY: get-orig-source
+get-orig-source:
+ rm -rf get-orig-source $(TARBALL)
+ mkdir get-orig-source
+ svn export -r $(SVN_REVISION) $(SVN_REPO) \
+ get-orig-source/$(PACKAGE)-$(SRC_VERSION).orig
+ GZIP='--best --no-name' tar czf $(TARBALL) -C get-orig-source $(PACKAGE)-$(SRC_VERSION).orig
+ rm -rf get-orig-source
+ echo " "$(TARBALL)" created; move it to the right destination to build the package"
+
+debian/open-axiom.1:
+ help2man --no-info \
+ --version-string='$(SRC_VERSION)' \
+ -m 'The open scientific computation platform' \
+ -n 'open source platform for symbolic, algebraic, and numerical computations' \
+ $(BUILD)/src/driver/open-axiom > $@
+
# make clean does not clean properly
# so building out of source
BUILD = build-tree
@@ -18,6 +40,9 @@ override_dh_auto_clean:
override_dh_install:
dh_install --list-missing
+override_dh_installman: debian/open-axiom.1
+ dh_installman
+
# AXIOMsys seems already stripped,
# and dh_strip breaks it
override_dh_strip:
@@ -32,17 +57,3 @@ override_dh_installdocs:
clean build install binary binary-arch binary-indep:
dh $@ --builddir=$(BUILD)
-PACKAGE = open-axiom
-SVN_REPO = https://open-axiom.svn.sf.net/svnroot/open-axiom/trunk
-SRC_VERSION := $(shell dpkg-parsechangelog | sed -ne 's/^Version: \(\([0-9]\+\):\)\?\(.*\)-.*/\3/p')
-SVN_REVISION := $(shell echo $(SRC_VERSION) | awk -F"+" '{ print $$2 }' | sed 's/svn~//' )
-TARBALL = $(PACKAGE)_$(SRC_VERSION).orig.tar.gz
-.PHONY: get-orig-source
-get-orig-source:
- rm -rf get-orig-source $(TARBALL)
- mkdir get-orig-source
- svn export -r $(SVN_REVISION) $(SVN_REPO) \
- get-orig-source/$(PACKAGE)-$(SRC_VERSION).orig
- GZIP='--best --no-name' tar czf $(TARBALL) -C get-orig-source $(PACKAGE)-$(SRC_VERSION).orig
- rm -rf get-orig-source
- echo " "$(TARBALL)" created; move it to the right destination to build the package"