summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2011-11-16 15:57:03 +0400
committerIgor Pashev <pashev.igor@gmail.com>2011-11-16 15:57:03 +0400
commit5e5ab51d7f64a82794bedc4b901488e081767baa (patch)
treeabcac71b4a8779ee41201defb2112eefef5267c3
parent7f7b5ed36cad77f4f13eae8a2a8dd5f30febec47 (diff)
downloadopen-axiom-debian-5e5ab51d7f64a82794bedc4b901488e081767baa.tar.gz
Get list of archs with SBCL from debian/control
-rw-r--r--debian/README.lisps9
-rwxr-xr-xdebian/rules5
2 files changed, 6 insertions, 8 deletions
diff --git a/debian/README.lisps b/debian/README.lisps
index a8e4fb5..040a877 100644
--- a/debian/README.lisps
+++ b/debian/README.lisps
@@ -1,12 +1,7 @@
-Lisps to build OpenAxiom:
-SBCL, GCL, CLisp, ECL, CCL
+Lisps to build OpenAxiom: SBCL, GCL, CLisp, ECL, CCL
SBCL is preferable, then GCL, then CLisp and so on.
+On archs where SBCL is unavailable, GCL should be used.
-As of Wheezy, SBCL is present only for:
-i386, amd64, kfreebsd-amd64.
-
-On other arch GCL should be used.
To build with GCL libncurses-dev and libreadline-dev are required.
-If changing lisp remember to edit debian/control, debian/rules and this file.
diff --git a/debian/rules b/debian/rules
index 2979f84..846dadd 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,7 +3,10 @@
DEB_HOST_ARCH := $(shell dpkg-architecture -qDEB_HOST_ARCH)
# List of archs currently having SBCL
-ifneq ($(filter $(DEB_HOST_ARCH), i386 amd64 kfreebsd-amd64),)
+# Keep build-deb on sbcl in one line: sbcl (...) [...],
+HAVE_SBCL := $(shell grep sbcl debian/control | sed -r 's,.*\[(.+)\].*,\1,')
+
+ifneq ($(filter $(DEB_HOST_ARCH), $(HAVE_SBCL)),)
LISP := sbcl
else
LISP := gcl