summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 2979f84..846dadd 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,7 +3,10 @@
DEB_HOST_ARCH := $(shell dpkg-architecture -qDEB_HOST_ARCH)
# List of archs currently having SBCL
-ifneq ($(filter $(DEB_HOST_ARCH), i386 amd64 kfreebsd-amd64),)
+# Keep build-deb on sbcl in one line: sbcl (...) [...],
+HAVE_SBCL := $(shell grep sbcl debian/control | sed -r 's,.*\[(.+)\].*,\1,')
+
+ifneq ($(filter $(DEB_HOST_ARCH), $(HAVE_SBCL)),)
LISP := sbcl
else
LISP := gcl