summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2013-10-31 16:56:54 +0400
committerIgor Pashev <pashev.igor@gmail.com>2013-10-31 16:56:54 +0400
commit41795de27021003eea72e7aed038beb260398a14 (patch)
treec77d9b8d9dc20af041a24042d6716799b2e4f02a
parent0c87e16daa02e715ff82b390c3429177b5ef9009 (diff)
downloadopen-axiom-debian-41795de27021003eea72e7aed038beb260398a14.tar.gz
Fixed get-orig-source target to work out of source tree
-rw-r--r--debian/changelog3
-rwxr-xr-xdebian/rules3
2 files changed, 4 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 22ff725..72d768a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -13,9 +13,10 @@ open-axiom (1.5.0~svn3056-1) unstable; urgency=low
* Use dh-buildinfo
* Override hardening-no-relro on usr/lib/open-axiom/bin/AXIOMsys
* Build depends on autotools-dev to update config.*
+ * Fixed get-orig-source target to work out of source tree.
* Bump standards version 3.9.3 → 3.9.4, no changes
- -- Igor Pashev <pashev.igor@gmail.com> Sat, 26 Oct 2013 16:47:53 +0400
+ -- Igor Pashev <pashev.igor@gmail.com> Thu, 31 Oct 2013 16:56:08 +0400
open-axiom (1.4.1+svn~2626-2) unstable; urgency=low
diff --git a/debian/rules b/debian/rules
index c9c2648..2ec1007 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,7 +17,8 @@ oa_libdir := /usr/lib/open-axiom
PACKAGE := open-axiom
SVN_REPO := svn://svn.code.sf.net/p/open-axiom/code/trunk
-SRC_VERSION := $(shell dpkg-parsechangelog | awk '/^Version:/ {sub(/-[^-]*/, "", $$2); print $$2}')
+DEBIAN_PATH := $(abspath $(dir $(firstword $(MAKEFILE_LIST))))
+SRC_VERSION := $(shell dpkg-parsechangelog -l$(DEBIAN_PATH)/changelog | awk '/^Version:/ {sub(/-[^-]*/, "", $$2); print $$2}')
SVN_REVISION := $(shell echo $(SRC_VERSION) | sed -r 's,.+svn([0-9]+),\1,')
TARBALL := $(PACKAGE)_$(SRC_VERSION).orig.tar.xz
.PHONY: get-orig-source