summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules3
1 files changed, 2 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index c9c2648..2ec1007 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,7 +17,8 @@ oa_libdir := /usr/lib/open-axiom
PACKAGE := open-axiom
SVN_REPO := svn://svn.code.sf.net/p/open-axiom/code/trunk
-SRC_VERSION := $(shell dpkg-parsechangelog | awk '/^Version:/ {sub(/-[^-]*/, "", $$2); print $$2}')
+DEBIAN_PATH := $(abspath $(dir $(firstword $(MAKEFILE_LIST))))
+SRC_VERSION := $(shell dpkg-parsechangelog -l$(DEBIAN_PATH)/changelog | awk '/^Version:/ {sub(/-[^-]*/, "", $$2); print $$2}')
SVN_REVISION := $(shell echo $(SRC_VERSION) | sed -r 's,.+svn([0-9]+),\1,')
TARBALL := $(PACKAGE)_$(SRC_VERSION).orig.tar.xz
.PHONY: get-orig-source