summaryrefslogtreecommitdiff
path: root/sci-mathematics/open-axiom/open-axiom-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/open-axiom/open-axiom-9999.ebuild')
-rw-r--r--sci-mathematics/open-axiom/open-axiom-9999.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/sci-mathematics/open-axiom/open-axiom-9999.ebuild b/sci-mathematics/open-axiom/open-axiom-9999.ebuild
index f50903c..58e5ef9 100644
--- a/sci-mathematics/open-axiom/open-axiom-9999.ebuild
+++ b/sci-mathematics/open-axiom/open-axiom-9999.ebuild
@@ -42,7 +42,7 @@ ecls? ( >=dev-lisp/ecls-0.9l )
clozurecl? ( >=dev-lisp/clozurecl-1.3 )"
choose_lisp() {
- if [ 1 != 2 ]; then
+ if [ ${CONF[$1]} != '.' ]; then
echo ${CONF[$1]}
else
echo ${LISPS[$1]}
@@ -90,13 +90,18 @@ src_configure() {
src_compile() {
# Parallel make broken
emake -j1 || die "emake failed"
- echo
+
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc ChangeLog* NEWS README AUTHORS MAINTAINERS TODO STYLES INSTALL
doicon ${FILESDIR}/open-axiom.png
- make_desktop_entry open-axiom OpenAxiom open-axiom || die
+ make_desktop_entry \
+ open-axiom \
+ OpenAxiom \
+ open-axiom \
+ "" \
+ "Terminal=true"
}