summaryrefslogtreecommitdiff
path: root/dev-libs/yaml-cpp/yaml-cpp-0.2.6.ebuild
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2011-08-10 15:32:28 +0400
committerIgor Pashev <pashev.igor@gmail.com>2011-08-10 15:32:28 +0400
commitf680b75881bd4221299f1be2c61df7c699f93645 (patch)
tree2362143560f37ea2109ccdebef3387a1f31fb371 /dev-libs/yaml-cpp/yaml-cpp-0.2.6.ebuild
parentcf53c5ceb7738ac885899f232a6b81cac017b135 (diff)
downloadebuilds-f680b75881bd4221299f1be2c61df7c699f93645.tar.gz
Added yaml-cpp-0.2.6.ebuild with patch to build by GCC 4.6
Diffstat (limited to 'dev-libs/yaml-cpp/yaml-cpp-0.2.6.ebuild')
-rw-r--r--dev-libs/yaml-cpp/yaml-cpp-0.2.6.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/yaml-cpp/yaml-cpp-0.2.6.ebuild b/dev-libs/yaml-cpp/yaml-cpp-0.2.6.ebuild
new file mode 100644
index 0000000..e568461
--- /dev/null
+++ b/dev-libs/yaml-cpp/yaml-cpp-0.2.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit cmake-utils
+
+
+DESCRIPTION="YAML parser and emitter in C++ matching the YAML 1.2 spec"
+LICENSE="MIT"
+HOMEPAGE="http://code.google.com/p/yaml-cpp/"
+SRC_URI="http://yaml-cpp.googlecode.com/files/${P}.tar.gz"
+SLOT="0"
+
+# No version in root dir of tarball:
+S="${WORKDIR}/${PN}"
+
+KEYWORDS="~x86 ~amd64"
+IUSE="+shared-libs +static-libs"
+REQUIRED_USE="|| ( shared-libs static-libs )"
+
+
+src_prepare() {
+ epatch "${FILESDIR}/gcc4.6-null.patch"
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build static-libs STATIC_LIBS)
+ $(cmake-utils_use_build shared-libs SHARED_LIBS)
+ )
+
+ cmake-utils_src_configure
+}
+