summaryrefslogtreecommitdiff
path: root/vim/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'vim/Makefile')
-rw-r--r--vim/Makefile70
1 files changed, 62 insertions, 8 deletions
diff --git a/vim/Makefile b/vim/Makefile
index 1d0193a..836d038 100644
--- a/vim/Makefile
+++ b/vim/Makefile
@@ -3,11 +3,11 @@ include /usr/share/cibs/rules/$(package).mk
include /usr/share/cibs/rules/hg.mk
bits = 64
-summary := the Editor
-license :=
-license-file := symlinks.license
+license := ViM
+license-file := vim.license
hg-url := https://vim.googlecode.com/hg/
+download := $(hg-url)
home := http://www.vim.org
name := vim
version := 7.3.905
@@ -16,7 +16,9 @@ hg-update := v$(subst .,-,$(version))
build-depends += \
developer/build/autoconf \
- developer/python
+ developer/python \
+ library/tinfo
+
pre-configure-stamp: autoconf-stamp
autoconf-stamp: patch-stamp
@@ -25,9 +27,13 @@ autoconf-stamp: patch-stamp
$(MAKE) -C $(sourcedir) distclean
touch $@
+$(eval $(call add-variant,basic))
$(eval $(call add-variant,nox))
$(eval $(call add-variant,tiny))
-$(eval $(call add-variant,basic))
+
+# Clean protodir, because they do not exist, e do not use them,
+# and pkg requires them to exist
+pkg-protos := -d .
configure-options := \
--prefix=/usr \
@@ -58,18 +64,66 @@ configure-options.basic := $(configure-options.nox) \
--disable-rubyinterp \
--disable-tclinterp \
+d_tmp := work/proto/tmp
+d_common := work/proto/vim-common
+d_runtime := work/proto/vim-runtime
+movefiles := /usr/share/cibs/scripts/movefiles
# We are building in source dir, but within subdirs:
+configure-%-stamp: SHADOWDIR=vim-$*
configure-%-stamp:
- $(MAKE) -C $(sourcedir)/src shadow SHADOWDIR=$(*)
+ $(MAKE) -C $(sourcedir)/src shadow SHADOWDIR=$(SHADOWDIR)
cd $(sourcedir) && if test -f src/auto/config.cache; then make distclean; fi
- cd $(sourcedir)/src/$(*) && \
+ cd $(sourcedir)/src/$(SHADOWDIR) && \
LDFLAGS="$(LDFLAGS)" CPPFLAGS="$(CPPFLAGS)" CFLAGS="$(CFLAGS)" CC="$(CC)"\
./configure $(configure-options.$*)
touch $@
+build-%-stamp: SHADOWDIR=vim-$*
build-%-stamp:
- $(MAKE) -C $(sourcedir)/src/$(*)
+ $(MAKE) -C $(sourcedir)/src/$(SHADOWDIR)
+ touch $@
+
+install-basic-stamp:
+ $(MAKE) -C $(sourcedir)/src/vim-basic DESTDIR=$(topdir)/$(d_tmp) \
+ installvimbin \
+ installtutorbin \
+ installgtutorbin \
+ installruntime \
+ installtools \
+ install-icons \
+ install-languages
+ rm -f $(protodir)/usr/bin/vim
+ touch $@
+
+install-nox-stamp install-tiny-stamp:
+ touch $@
+
+post-install-stamp: vim-common-stamp vim-runtime-stamp
+vim-common-stamp: install-stamp
+ mkdir -p $(d_common)
+ $(movefiles) -s $(d_tmp) -d $(d_common) \
+ usr/bin/xxd \
+ usr/share/man/man1/xxd.1 \
+ usr/share/man/man1/vimdiff.1 \
+ usr/share/man/man1/vim.1
+ mkdir -p $(d_common)/etc/vim
+ mkdir -p $(d_common)/usr/share/vim
+ mkdir -p $(d_common)/var/lib/vim/addons
+ cp vimrc $(d_common)/etc/vim/vimrc
+ ln -sf ../../../etc/vim $(d_common)/usr/share/vim/vimfiles
+ ln -sf ../../../etc/vim/vimrc $(d_common)/usr/share/vim/vimrc
+ ln -sf vim73 $(d_common)/usr/share/vim/vimcurrent
+ ln -sf vim.1 $(d_common)/usr/share/man/man1/rvim.1
+ ln -sf vim.1 $(d_common)/usr/share/man/man1/rview.1
+ touch $@
+
+vim-runtime-stamp: install-stamp
+ mkdir -p $(d_runtime)
+ $(movefiles) -s $(d_tmp) -d $(d_runtime) \
+ usr/bin/vimtutor \
+ usr/share/man/man1/vimtutor.1 \
+ usr/share/vim
touch $@