summaryrefslogtreecommitdiff
path: root/zeromq
diff options
context:
space:
mode:
authorIgor Pashev <igor.pashev@nexenta.com>2012-10-24 14:48:04 +0400
committerIgor Pashev <igor.pashev@nexenta.com>2012-10-24 14:48:04 +0400
commit98cb3b26f4043c9a83029c21855ff61b7601e611 (patch)
treee0e08eb9e6a168c65444dfc9751a522cb08b0ab3 /zeromq
downloadcibs-pkgs-98cb3b26f4043c9a83029c21855ff61b7601e611.tar.gz
Initial commit from cibs/examples
Diffstat (limited to 'zeromq')
-rw-r--r--zeromq/Makefile32
-rw-r--r--zeromq/zeromq.p5m27
2 files changed, 59 insertions, 0 deletions
diff --git a/zeromq/Makefile b/zeromq/Makefile
new file mode 100644
index 0000000..5b20f6d
--- /dev/null
+++ b/zeromq/Makefile
@@ -0,0 +1,32 @@
+include /usr/share/cibs/rules/ips.mk
+include /usr/share/cibs/rules/archive.mk
+#include /usr/share/cibs/rules/patch.mk
+#include /usr/share/cibs/rules/autoreconf.mk
+include /usr/share/cibs/rules/autotools.mk
+include /usr/share/cibs/rules/32.mk
+include /usr/share/cibs/rules/64.mk
+
+
+summary := The ZeroMQ messaging library
+license := LGPL
+license-file := COPYING.LESSER
+
+build-depends += \
+ pkg:/library/libpgm
+
+#/usr/gcc/4.3/bin/gcc -m32 -luuid -o test
+#ld: warning: file libdladm.so.1: required by /usr/lib/libdlpi.so.1, not found
+configure-env += LDFLAGS="-L/lib"
+
+configure-options += --with-system-pgm
+
+home := http://www.zeromq.org
+name := zeromq
+version := 2.2.0
+archive := $(name)-$(version).tar.gz
+download := http://download.zeromq.org/$(archive)
+checksum := \
+ md5:1b11aae09b19d18276d0717b2ea288f6 \
+ sha1:e4bc024c33d3e62f658640625e061ce4e8bd1ff1 \
+ sha256:43904aeb9ea6844f72ca02e4e53bf1d481a1a0264e64979da761464e88604637 \
+ size:1900378
diff --git a/zeromq/zeromq.p5m b/zeromq/zeromq.p5m
new file mode 100644
index 0000000..aa78982
--- /dev/null
+++ b/zeromq/zeromq.p5m
@@ -0,0 +1,27 @@
+set name=pkg.fmri value=pkg:/library/zeromq@$(ips-version)
+set name=pkg.summary value="$(summary)"
+set name=info.upstream-url value="$(home)"
+set name=info.source_url value="$(download)"
+license $(license-file) license="$(license)"
+
+dir path=usr
+dir path=usr/include
+dir path=usr/lib
+dir path=usr/lib/$(MACH64)
+dir path=usr/lib/$(MACH64)/pkgconfig
+dir path=usr/lib/pkgconfig
+dir path=usr/share
+dir path=usr/share/man
+dir path=usr/share/man/man3
+dir path=usr/share/man/man7
+file path=usr/include/zmq.h
+file path=usr/include/zmq.hpp
+file path=usr/include/zmq_utils.h
+file path=usr/lib/$(MACH64)/libzmq.so.1.0.1
+file path=usr/lib/$(MACH64)/pkgconfig/libzmq.pc
+file path=usr/lib/libzmq.so.1.0.1
+file path=usr/lib/pkgconfig/libzmq.pc
+link path=usr/lib/$(MACH64)/libzmq.so target=libzmq.so.1.0.1
+link path=usr/lib/$(MACH64)/libzmq.so.1 target=libzmq.so.1.0.1
+link path=usr/lib/libzmq.so target=libzmq.so.1.0.1
+link path=usr/lib/libzmq.so.1 target=libzmq.so.1.0.1