summaryrefslogtreecommitdiff
path: root/symlinks
diff options
context:
space:
mode:
authorIgor Pashev <igor.pashev@nexenta.com>2012-10-24 14:48:04 +0400
committerIgor Pashev <igor.pashev@nexenta.com>2012-10-24 14:48:04 +0400
commit98cb3b26f4043c9a83029c21855ff61b7601e611 (patch)
treee0e08eb9e6a168c65444dfc9751a522cb08b0ab3 /symlinks
downloadcibs-pkgs-98cb3b26f4043c9a83029c21855ff61b7601e611.tar.gz
Initial commit from cibs/examples
Diffstat (limited to 'symlinks')
-rw-r--r--symlinks/Makefile31
-rw-r--r--symlinks/patches/largefile.diff20
-rw-r--r--symlinks/patches/manpage.diff15
-rw-r--r--symlinks/symlinks.license21
-rw-r--r--symlinks/symlinks.p5m10
5 files changed, 97 insertions, 0 deletions
diff --git a/symlinks/Makefile b/symlinks/Makefile
new file mode 100644
index 0000000..7b78b60
--- /dev/null
+++ b/symlinks/Makefile
@@ -0,0 +1,31 @@
+include /usr/share/cibs/rules/ips.mk
+include /usr/share/cibs/rules/git.mk
+include /usr/share/cibs/rules/patch.mk
+include /usr/share/cibs/rules/32.mk
+
+
+summary := scan/change symbolic links
+license := PD-like
+license-file := symlinks.license
+
+home := http://packages.debian.org/source/sid/symlinks
+name := symlinks
+version := 1.4
+git-url := http://anonscm.debian.org/git/users/joachim-guest/symlinks.git
+
+# Tag, commit or branch. Passed to git checkout as is:
+# git checkout $(git-checkout)
+git-checkout := upstream/$(version)
+
+configure-%-stamp:
+ touch $@
+
+build-%-stamp: download-stamp patch-stamp
+ [ -d "$(builddir)" ] || mkdir -p "$(builddir)"
+ $(CC) $(CFLAGS) $(sourcedir)/symlinks.c -o $(builddir)/symlinks
+ touch $@
+
+install-%-stamp: build-%-stamp
+ mkdir -p $(destdir)/$(bindir)
+ cp $(builddir)/symlinks $(destdir)/$(bindir)
+ touch $@
diff --git a/symlinks/patches/largefile.diff b/symlinks/patches/largefile.diff
new file mode 100644
index 0000000..c62b3ca
--- /dev/null
+++ b/symlinks/patches/largefile.diff
@@ -0,0 +1,20 @@
+Description: Fix warning on large files
+ On files > 2GB on 32-bit systems, symlinks would print annyoing error
+ messages "Value too large for defined data type".
+Author: Eduard Bloch <edi@gmx.de>
+Bug-Debian: http://bugs.debian.org/167122
+
+---
+ symlinks.c | 14 ++++++++++++++
+ 1 file changed, 14 insertions(+)
+
+--- a/symlinks.c
++++ b/symlinks.c
+@@ -1,3 +1,7 @@
++#define _FILE_OFFSET_BITS 64
++#define _LARGEFILE_SOURCE
++#define _LARGEFILE64_SOURCE
++
+ #include <unistd.h>
+ #ifndef _POSIX_SOURCE
+ #define _POSIX_SOURCE
diff --git a/symlinks/patches/manpage.diff b/symlinks/patches/manpage.diff
new file mode 100644
index 0000000..ab28a38
--- /dev/null
+++ b/symlinks/patches/manpage.diff
@@ -0,0 +1,15 @@
+Description: Fix section of the symlinks manpage
+Author: Sven Joachim <svenjoac@gmx.de>
+
+---
+ symlinks.8 | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/symlinks.8
++++ b/symlinks.8
+@@ -1,4 +1,4 @@
+-.TH SYMLINKS 8 "October 2008" "Version 1.4"
++.TH SYMLINKS 1 "October 2008" "Version 1.4"
+
+ .SH NAME
+ symlinks \- symbolic link maintenance utility
diff --git a/symlinks/symlinks.license b/symlinks/symlinks.license
new file mode 100644
index 0000000..3d6574c
--- /dev/null
+++ b/symlinks/symlinks.license
@@ -0,0 +1,21 @@
+Copyright (C) 2009 Mark Lord, freely distributable
+
+Hi,
+
+My "symlinks" utility pre-dates the "open source licensing" fad
+by a number of years. Just to clarify, this is 100% freeware,
+written entirely by myself. The intent is to use it to detect
+missing/obsolete symlink targets on an installed distro, before
+creating the "gold" (or "final") release discs.
+
+Use and distribute and modify as you (or anyone else) sees fit.
+There have no formal restrictions or requirements whatsoever
+regarding distribution of either binaries or source code,
+whether modified or original.
+
+Cheers
+--
+Mark Lord
+Real-Time Remedies Inc.
+mlord@pobox.com
+
diff --git a/symlinks/symlinks.p5m b/symlinks/symlinks.p5m
new file mode 100644
index 0000000..762f42a
--- /dev/null
+++ b/symlinks/symlinks.p5m
@@ -0,0 +1,10 @@
+set name=pkg.fmri value=pkg:/file/$(name)@$(ips-version)
+set name=pkg.summary value="$(summary)"
+set name=info.upstream-url value="$(home)"
+set name=info.source-url value="$(git-url)"
+
+license $(license-file) license=$(license)
+
+file path=usr/bin/symlinks
+file symlinks.8 path=usr/share/man/man1/symlinks.1
+