summaryrefslogtreecommitdiff
path: root/libv8
diff options
context:
space:
mode:
authorIgor Pashev <igor.pashev@nexenta.com>2012-10-31 17:42:24 +0400
committerIgor Pashev <igor.pashev@nexenta.com>2012-10-31 17:42:24 +0400
commit0debda6e0f9b7eed9989288576843eefa6438a64 (patch)
tree48b598b4f7e97e44e20052505c89f788c177d725 /libv8
parent5806b415e14a73d87a4d72a1f4567fd2d7e24c1a (diff)
downloadcibs-pkgs-0debda6e0f9b7eed9989288576843eefa6438a64.tar.gz
V8
Diffstat (limited to 'libv8')
-rw-r--r--libv8/Makefile65
-rw-r--r--libv8/libv8-headers.p5m20
-rw-r--r--libv8/libv8.p5m8
3 files changed, 93 insertions, 0 deletions
diff --git a/libv8/Makefile b/libv8/Makefile
new file mode 100644
index 0000000..cce0d45
--- /dev/null
+++ b/libv8/Makefile
@@ -0,0 +1,65 @@
+include /usr/share/cibs/rules/ips.mk
+include /usr/share/cibs/rules/copy.mk
+include /usr/share/cibs/rules/archive.mk
+include /usr/share/cibs/rules/64.mk
+
+
+summary := v8 JavaScript engine
+home := http://code.google.com/p/v8/
+license := BSD
+license-file := LICENSE.v8
+version := 3.8.9.20
+so-version := $(version)
+name := libv8
+libSoname := $(name).so.$(so-version)
+
+build-depends += \
+ pkg:/developer/build/gyp
+
+archive := libv8_$(version).orig.tar.gz
+download := http://ftp.de.debian.org/debian/pool/main/libv/libv8/$(archive)
+checksum := \
+ md5:42e6ebd3a04d4532a5bbc2eaf3375f46 \
+ sha1:0f4898f5209014db2cd561d34c9eaf44cf98bec2 \
+ sha256:b03af91f1a111a959f133ca930497294b8faf134203a610998be2b5dd64253d1 \
+ size:11373638
+
+
+v8arch.32 := ia32
+v8arch.64 := x64
+v8arch = $(v8arch.$(bits))
+
+v8os := solaris
+v8out = $(builddir)/out/$(v8arch).release/lib.target/$(libSoname)
+
+GYPFLAGS = \
+ -Dhost_arch=$(v8arch) \
+ -DOS=$(v8os)
+
+export GYPFLAGS
+
+patch-stamp: gyp-stamp
+gyp-stamp:
+ # Use system GYP
+ gsed -i 's,build/gyp/,,g' $(sourcedir)/Makefile
+ touch $@
+
+configure-%-stamp: pre-configure-stamp
+ touch $@
+
+build-%-stamp: configure-%-stamp
+ $(MAKE) -C $(builddir) \
+ V=1 \
+ CXX="$(CXX)" \
+ LINK="$(CXX)" \
+ library=shared \
+ soname_version=$(so-version) \
+ werror=no \
+ $(v8arch).release
+ touch $@
+
+install-%-stamp: build-%-stamp
+ mkdir -p $(protodir)/$(libdir)
+ mkdir -p $(protodir)/usr/include
+ cp $(v8out) $(protodir)/$(libdir)/
+
diff --git a/libv8/libv8-headers.p5m b/libv8/libv8-headers.p5m
new file mode 100644
index 0000000..6349f4d
--- /dev/null
+++ b/libv8/libv8-headers.p5m
@@ -0,0 +1,20 @@
+set name=pkg.fmri value=pkg:/library/$(name)-headers@$(ips-version)
+set name=pkg.summary value="$(summary), header files"
+set name=info.upstream-url value="$(home)"
+set name=info.source-url value="$(download)"
+license $(license-file) license="$(license)"
+
+depend fmri=pkg:/library/$(name)@$(ips-version) type=require
+depend fmri=pkg:/library/$(name)@$(ips-version) type=incorporate
+
+
+
+file include/v8-debug.h path=usr/include/v8-debug.h
+file include/v8-preparser.h path=usr/include/v8-preparser.h
+file include/v8-profiler.h path=usr/include/v8-profiler.h
+file include/v8-testing.h path=usr/include/v8-testing.h
+file include/v8.h path=usr/include/v8.h
+file include/v8stdint.h path=usr/include/v8stdint.h
+
+link path=usr/lib/$(mach64)/libv8.so target=libv8.so.$(so-version)
+
diff --git a/libv8/libv8.p5m b/libv8/libv8.p5m
new file mode 100644
index 0000000..788bb68
--- /dev/null
+++ b/libv8/libv8.p5m
@@ -0,0 +1,8 @@
+set name=pkg.fmri value=pkg:/library/$(name)-$(so-version)@$(ips-version)
+set name=pkg.summary value="$(summary), shared library, version $(so-version)"
+set name=info.upstream-url value="$(home)"
+set name=info.source-url value="$(download)"
+license $(license-file) license="$(license)"
+
+file path=usr/lib/$(mach64)/libv8.so.$(so-version)
+