summaryrefslogtreecommitdiff
path: root/gyp
diff options
context:
space:
mode:
authorIgor Pashev <igor.pashev@nexenta.com>2013-02-18 17:37:08 +0400
committerIgor Pashev <igor.pashev@nexenta.com>2013-02-18 17:37:08 +0400
commit6987c942a11bab3b146da8221f4e2c42373ae596 (patch)
tree6286e1235a22368ad43ce3d0fcf5c270e8c2361d /gyp
parentbe28bbbafb85efc2cffc58b51090952432e5fb64 (diff)
downloadcibs-pkgs-6987c942a11bab3b146da8221f4e2c42373ae596.tar.gz
Allow building debs
Diffstat (limited to 'gyp')
-rw-r--r--gyp/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/gyp/Makefile b/gyp/Makefile
index 8033e98..db44f50 100644
--- a/gyp/Makefile
+++ b/gyp/Makefile
@@ -1,4 +1,5 @@
-include /usr/share/cibs/rules/ips.mk
+package ?= ips
+include /usr/share/cibs/rules/$(package).mk
include /usr/share/cibs/rules/copy.mk
include /usr/share/cibs/rules/archive.mk
include /usr/share/cibs/rules/noarch.mk
@@ -33,7 +34,7 @@ build-%-stamp: configure-%-stamp
touch $@
install-%-stamp: build-%-stamp
- cd $(builddir) && python2.6 setup.py install --root="$(protodir)" \
+ cd $(builddir) && python2.6 setup.py install --root="$(topdir)/$(protodir)" \
--install-lib=/usr/lib/python2.6/vendor-packages
gsed -i 's,#!.*,#!/usr/bin/python2.6,' $(protodir)/usr/bin/gyp
touch $@