summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor Pashev <igor.pashev@nexenta.com>2013-01-24 11:05:02 +0400
committerIgor Pashev <igor.pashev@nexenta.com>2013-01-24 11:23:38 +0400
commit8f2408f3db4fb1fb802bfa4c7b89d8e86ffc417b (patch)
treeba5ed3c1583408cb284fc2019c7dc9c233064836
parent1d91ed0fe08f89f93113217d4ab47b2c3a53f1d1 (diff)
downloadcibs-pkgs-8f2408f3db4fb1fb802bfa4c7b89d8e86ffc417b.tar.gz
libczmq 1.3.2
-rw-r--r--libczmq/Makefile32
-rw-r--r--libczmq/libczmq.p5m49
-rw-r--r--libczmq/libczmq1.p5m12
3 files changed, 93 insertions, 0 deletions
diff --git a/libczmq/Makefile b/libczmq/Makefile
new file mode 100644
index 0000000..beb8c3b
--- /dev/null
+++ b/libczmq/Makefile
@@ -0,0 +1,32 @@
+package ?= ips
+
+include /usr/share/cibs/rules/$(package).mk
+include /usr/share/cibs/rules/archive.mk
+include /usr/share/cibs/rules/autotools.mk
+include /usr/share/cibs/rules/32.mk
+include /usr/share/cibs/rules/64.mk
+
+# Manpages are not installed if building out-of-source.
+# Yes! Just like libzmq
+include /usr/share/cibs/rules/copy.mk
+
+summary := High-level C Binding for ZeroMQ
+license := LGPL
+license-file := COPYING.LESSER
+
+build-depends += \
+ library/libzmq \
+ developer/pkg-config
+
+home := http://czmq.zeromq.org/
+name := czmq
+version := 1.3.2
+archive := $(name)-$(version).tar.gz
+download := http://download.zeromq.org/$(archive)
+
+checksum-czmq-1.3.2.tar.gz := \
+ md5:513fb1f9a7030c71c7d9a3a61f9970db \
+ sha1:09354c07cad4570d1360ad197c5f979c8f58847e \
+ sha256:c9459a2b78f604f956b2ba99abd5608653ff2ef5ab70e405ab05f2b9f2d3656c \
+ size:422847
+
diff --git a/libczmq/libczmq.p5m b/libczmq/libczmq.p5m
new file mode 100644
index 0000000..5c88b6e
--- /dev/null
+++ b/libczmq/libczmq.p5m
@@ -0,0 +1,49 @@
+set name=pkg.fmri value=pkg:/library/libczmq@$(ips-version)
+set name=pkg.summary value="$(summary)"
+set name=info.upstream-url value="$(home)"
+set name=info.source-url value="$(download)"
+
+license $(license-file) license="$(license)"
+
+depend fmri=pkg:/library/libczmq1@$(ips-version) type=require
+depend fmri=pkg:/library/libczmq1@$(ips-version) type=incorporate
+
+file path=usr/bin/czmq_selftest
+file path=usr/share/man/man7/czmq.7
+file path=usr/share/man/man7/zmsg.7
+file path=usr/share/man/man7/zctx.7
+file path=usr/share/man/man7/zmutex.7
+file path=usr/share/man/man7/zsocket.7
+file path=usr/share/man/man7/zfile.7
+file path=usr/share/man/man7/zlist.7
+file path=usr/share/man/man7/zhash.7
+file path=usr/share/man/man7/zthread.7
+file path=usr/share/man/man7/zframe.7
+file path=usr/share/man/man7/zsockopt.7
+file path=usr/share/man/man7/zstr.7
+file path=usr/share/man/man7/zloop.7
+file path=usr/share/man/man7/zclock.7
+
+$(build64)file path=usr/lib/$(mach64)/pkgconfig/libczmq.pc
+$(build64)file path=usr/lib/$(mach64)/libczmq.a
+$(build64)link path=usr/lib/$(mach64)/libczmq.so target=libczmq.so.1
+
+$(build32)file path=usr/lib/pkgconfig/libczmq.pc
+$(build32)file path=usr/lib/libczmq.a
+$(build32)link path=usr/lib/libczmq.so target=libczmq.so.1
+
+file path=usr/include/zloop.h
+file path=usr/include/zctx.h
+file path=usr/include/zclock.h
+file path=usr/include/zmsg.h
+file path=usr/include/czmq.h
+file path=usr/include/czmq_prelude.h
+file path=usr/include/zframe.h
+file path=usr/include/zhash.h
+file path=usr/include/zlist.h
+file path=usr/include/zthread.h
+file path=usr/include/zfile.h
+file path=usr/include/zstr.h
+file path=usr/include/zmutex.h
+file path=usr/include/zsocket.h
+file path=usr/include/zsockopt.h
diff --git a/libczmq/libczmq1.p5m b/libczmq/libczmq1.p5m
new file mode 100644
index 0000000..cd2a08e
--- /dev/null
+++ b/libczmq/libczmq1.p5m
@@ -0,0 +1,12 @@
+set name=pkg.fmri value=pkg:/library/libczmq1@$(ips-version)
+set name=pkg.summary value="$(summary), shared library"
+set name=info.upstream-url value="$(home)"
+set name=info.source-url value="$(download)"
+
+license $(license-file) license="$(license)"
+
+$(build64)file path=usr/lib/$(mach64)/libczmq.so.1.0.0
+$(build64)link path=usr/lib/$(mach64)/libczmq.so.1 target=libczmq.so.1.0.0
+
+$(build32)file path=usr/lib/libczmq.so.1.0.0
+$(build32)link path=usr/lib/libczmq.so.1 target=libczmq.so.1.0.0