summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor Pashev <igor.pashev@nexenta.com>2013-01-25 17:23:45 +0400
committerIgor Pashev <igor.pashev@nexenta.com>2013-01-25 17:23:45 +0400
commit8dcd93dcfb70bbcaeeafbfaddb7aa6a300d11570 (patch)
treed0a2047bf43ccff9b001b7385b583dc79279a358
parentc01093e13ecce8a9e646fd3e2fefae8d26bcfdf4 (diff)
downloadcibs-pkgs-8dcd93dcfb70bbcaeeafbfaddb7aa6a300d11570.tar.gz
Use help2man to produce 2to3 man page
-rw-r--r--python2.7/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/python2.7/Makefile b/python2.7/Makefile
index 50e7c2c..806ebac 100644
--- a/python2.7/Makefile
+++ b/python2.7/Makefile
@@ -34,6 +34,8 @@ build-depends += \
library/readline \
library/tinfo \
library/zlib \
+ text/help2man \
+
configure-options += \
--without-gcc \
@@ -71,12 +73,18 @@ postinst-stamp: install-default-stamp
ln -sf ../lib/python$(VER)/pdb.py $(d)/usr/bin/pdb$(VER)
: # versioned install only
rm -f $(d)/usr/bin/python-config
- mv $(d)/usr/bin/2to3 $(d)/usr/bin/2to3-$(VER)
mv $(d)/usr/bin/pydoc $(d)/usr/bin/pydoc$(VER)
: # Remove version information from the egg-info file
mv $(d)/$(scriptdir)/lib-dynload/Python-$(VER)*.egg-info \
$(d)/$(scriptdir)/lib-dynload/Python-$(VER).egg-info
cp -p $(sourcedir)/Tools/i18n/pygettext.py $(d)/usr/bin/pygettext$(VER)
+ mv $(d)/usr/bin/2to3 $(d)/usr/bin/2to3-$(VER)
+ PYTHONPATH=$(d)/$(scriptdir) \
+ help2man --no-info --version-string=$(VER) --no-discard-stderr \
+ --name 'Python2 to Python3 converter' \
+ $(d)/usr/bin/2to3-$(VER) \
+ > $(d)/usr/share/man/man1/2to3-$(VER).1
+
touch $@