aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-11-06 00:07:17 +0000
committerfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-11-06 00:07:17 +0000
commit8a057e77affc16bf477faa0983529229c11bce68 (patch)
tree93c999c57cf0cd31727943e45dc53293514c5def /debian
parent8d8639711db25172fb3d0b41ef6874d6a3d1daa4 (diff)
downloadpandoc-8a057e77affc16bf477faa0983529229c11bce68.tar.gz
Modified build procedure to allow compilation with GHC 6.8:
+ pandoc.cabal now uses Cabal configurations and requires Cabal >=1.2. + An alternative pandoc.cabal.ghc66 is provided for those who have older versions of Cabal. + Debian build process has been modified to use pandoc.cabal.ghc66, as a temporary measure until GHC 6.8 gets into debian unstable. + INSTALL instructions have been updated. + Makefile has been updated to accommodate changes in pandoc.cabal. + pandoc.cabal.ghc68 has been removed, since the default version now works with GHC 6.8. git-svn-id: https://pandoc.googlecode.com/svn/trunk@1066 788f1e2b-df1e-0410-8736-df70ead52e1b
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog8
-rw-r--r--debian/control1
-rwxr-xr-xdebian/rules20
3 files changed, 26 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 92aed42e0..a19e92c12 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -117,6 +117,10 @@ pandoc (0.45) unstable; urgency=low
* Removed 'version' constant from Main.hs; added 'pandocVersion' to
Text.Pandoc library.
+ * Modified Makefile to work with Cabal configurations and GHC 6.8.
+ Provide pandoc.cabal.ghc66 for people who are still using older
+ versions of Cabal, which don't support configurations.
+
* Fixed MacPorts Portfile:
+ Modified to install the pandoc library in addition to programs.
@@ -134,6 +138,10 @@ pandoc (0.45) unstable; urgency=low
[ Recai OktaÅŸ ]
+ * Revised debian/rules to use pandoc.cabal.ghc66, as a transition
+ measure until GHC 6.8 gets into debian. Modified debian/control
+ to require GHC 6.6, as a safety measure.
+
* Makefile: fix the issue of having two copies of the library documentation
under some usage scenarios.
diff --git a/debian/control b/debian/control
index 0518be017..f906710e4 100644
--- a/debian/control
+++ b/debian/control
@@ -4,6 +4,7 @@ Priority: optional
Maintainer: Recai OktaÅŸ <roktas@debian.org>
Build-Depends: debhelper (>= 4.0.0), haskell-devscripts (>=0.5.12), ghc6 (>= 6.6-1), libghc6-xhtml-dev, libghc6-mtl-dev, libghc6-network-dev, perl
Build-Depends-Indep: haddock
+Build-Conflicts: ghc6 (>= 6.8), ghc6 (<= 6.4)
Standards-Version: 3.7.2.0
XS-Vcs-Svn: http://pandoc.googlecode.com/svn/trunk
XS-Vcs-Browser: http://pandoc.googlecode.com/svn/trunk
diff --git a/debian/rules b/debian/rules
index 8e3dc240f..ba2baf00e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,7 @@
#!/usr/bin/make -f
#
# debian/rules for pandoc.
-# Copyright © 2006 Recai Oktaş <roktasATdebian.org>
+# Copyright © 2006 Recai Oktaþ <roktasATdebian.org>
#
# This file is based on John Goerzen's Cabal Debian template.
# See http://www.n-heptane.com/nhlab/repos/cabalDebianTemplate/
@@ -33,8 +33,22 @@ endif
# Export all variables which will be used in various stages of build process.
export PREFIX DESTDIR DATADIR DOCDIR HCFLAGS
+# Special code dealing with ghc 6.6 -> 6.8 transition.
+.PHONY: cabalbackup cabalrestore
+cabalbackup: $(THIS).cabal.ghccurrent
+$(THIS).cabal.ghccurrent:
+ if [ -f $(THIS).cabal.ghc66 ]; then \
+ mv $(THIS).cabal $(THIS).cabal.ghccurrent; \
+ cp $(THIS).cabal.ghc66 $(THIS).cabal; \
+ fi
+cabalrestore:
+ # Special code dealing with ghc 6.6 -> 6.8 transition.
+ if [ -f $(THIS).cabal.ghc66 ] && [ -f $(THIS).cabal.ghccurrent ]; then \
+ mv $(THIS).cabal.ghccurrent $(THIS).cabal; \
+ fi
+
configure: configure-stamp
-configure-stamp:
+configure-stamp: cabalbackup
dh_testdir
$(MAKE) configure
@@ -120,5 +134,5 @@ binary-arch: build install
dh_md5sums -a
dh_builddeb -a
-binary: binary-indep binary-arch
+binary: binary-indep binary-arch cabalrestore
.PHONY: build clean binary-indep binary-arch binary install build-indep install-indep