aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorroktas <roktas@788f1e2b-df1e-0410-8736-df70ead52e1b>2006-10-29 12:54:08 +0000
committerroktas <roktas@788f1e2b-df1e-0410-8736-df70ead52e1b>2006-10-29 12:54:08 +0000
commit40a8480efdf2a073c3741b11970a2a3f71dce83a (patch)
tree4f380f46a8846b5d39d26af3ccc8155b1651217c /debian/rules
parent09473903dc473d29526c023cf5018c21b5ac7805 (diff)
downloadpandoc-40a8480efdf2a073c3741b11970a2a3f71dce83a.tar.gz
Remove 'install-lib', it causes too much trouble which needs to be dealed
in ugly ways. + Now, we have 'install-program' and 'install-all' targets. The former installs only program and user documents, while the latter installs everything: program, user documents, library files and library documents. + Behaviour of 'install' target hasn't changed, it calls 'install-program'. + Update README accordingly. + Implement missing uninstall-* targets (including 'uninstall-all' and 'uninstall-program' for the new targets). + Call 'install-program' in debian/rules explicitly to prevent confusions. git-svn-id: https://pandoc.googlecode.com/svn/trunk@33 788f1e2b-df1e-0410-8736-df70ead52e1b
Diffstat (limited to 'debian/rules')
-rw-r--r--debian/rules2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 7c0f98547..54f8eec4e 100644
--- a/debian/rules
+++ b/debian/rules
@@ -67,7 +67,7 @@ install: build
# http://www.n-heptane.com/nhlab/repos/cabalDebianTemplate/INSTRUCTIONS.txt
find debian/libghc6-$(THIS)-dev -type d -name 'bin' -true | \
while read bin; do mv $$bin/* .; rm -rf $$bin; done
- $(MAKE) install
+ $(MAKE) install-program
build-indep: build-indep-stamp
build-indep-stamp: