aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 17 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b270895d..08df2a22 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,6 @@
sinclude(config/open-axiom.m4)
sinclude(config/aclocal.m4)
-AC_INIT([OpenAxiom], [1.3.0-2008-10-29],
+AC_INIT([OpenAxiom], [1.3.0-2008-10-31],
[open-axiom-bugs@lists.sf.net])
AC_CONFIG_AUX_DIR(config)
@@ -451,8 +451,23 @@ AC_CHECK_DECLS([fork],
[],
[#include <unistd.h>])
+## Does this system have openpty or shall we emulate?
+AC_CHECK_HEADERS([pty.h util.h])
+AC_CHECK_DECLS([openpty],[],[],
+ [#if HAVE_PTY_H
+ # include <pty.h>
+ #endif
+ #if HAVE_UTIL_H
+ # include <util.h>
+ #endif
+ ])
+if test x"$ac_cv_have_decl_openpty" = xyes; then \
+ AC_SEARCH_LIBS([openpty],[util])
+fi
+
axiom_use_sman=1
-if test x"$ac_cv_have_decl_fork" = xyes \
+if test x"$ac_cv_header_pty_h" = xyes \
+ -a x"$ac_cv_have_decl_fork" = xyes \
-a x"$ac_cv_have_decl_wait" = xyes; then \
axiom_c_runtime="$axiom_c_runtime terminal_io"
axiom_src_all="$axiom_src_all all-sman all-clef"