aboutsummaryrefslogtreecommitdiff
path: root/src/algebra/Makefile.am
diff options
context:
space:
mode:
authorGabriel Dos Reis <gdr@axiomatics.org>2016-01-19 04:16:43 -0800
committerGabriel Dos Reis <gdr@axiomatics.org>2016-01-19 04:16:43 -0800
commit9130fc21789dd3fc7c1a8c89dc992acfb54dbccd (patch)
treeb42cb9f365a75b6299fcb0942eba4be57d941416 /src/algebra/Makefile.am
parentd07fc9735f40e545edda456e15dbab783c500f6a (diff)
downloadopen-axiom-9130fc21789dd3fc7c1a8c89dc992acfb54dbccd.tar.gz
getConstructorCategory: get it from generated code for category constructors.
Diffstat (limited to 'src/algebra/Makefile.am')
-rw-r--r--src/algebra/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/algebra/Makefile.am b/src/algebra/Makefile.am
index 30385bcc..4308614b 100644
--- a/src/algebra/Makefile.am
+++ b/src/algebra/Makefile.am
@@ -1188,7 +1188,9 @@ strap-2/KONVERT.$(FASLEXT): strap-2/TYPE.$(FASLEXT)
strap-2/RETRACT.$(FASLEXT): strap-2/KRCFROM.$(FASLEXT)
strap-2/BASTYPE.$(FASLEXT): strap-2/TYPE.$(FASLEXT) \
strap-1/BOOLEAN.$(FASLEXT) strap-1/KOERCE.$(FASLEXT)
-strap-2/FRETRCT.$(FASLEXT): strap-2/RETRACT.$(FASLEXT) strap-1/INS.$(FASLEXT)
+strap-2/FRETRCT.$(FASLEXT): strap-2/RETRACT.$(FASLEXT) \
+ strap-1/INS.$(FASLEXT) \
+ strap-1/TBAGG.$(FASLEXT)
strap-2/SETCAT.$(FASLEXT): strap-2/BASTYPE.$(FASLEXT) \
strap-2/KOERCE.$(FASLEXT) strap-1/SINT.$(FASLEXT) \
strap-1/STRING.$(FASLEXT) strap-1/OUTFORM.$(FASLEXT)