aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authordos-reis <gdr@axiomatics.org>2013-06-28 05:02:14 +0000
committerdos-reis <gdr@axiomatics.org>2013-06-28 05:02:14 +0000
commit50ec7502934e4632348f4c3c8e060181f199dfc8 (patch)
treecd60fa76d27d654344f093a326222ff21685701b /src/Makefile.am
parentb52f0164b18f06db386d527be26e3a11deb1ab7d (diff)
downloadopen-axiom-50ec7502934e4632348f4c3c8e060181f199dfc8.tar.gz
Add src/rt for core runtime support.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5a35b8ac..c0701075 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -35,7 +35,7 @@ DIST_SUBDIRS = \
driver etc graph hyper \
include input interp lib \
lisp scripts share sman \
- testsuite utils io syntax
+ testsuite utils io syntax rt
subdirs = \
algebra boot clef doc driver \
@@ -60,7 +60,9 @@ oa_src_include_headers = \
vm.H \
token.H \
sexpr.H \
- Lisp.H
+ Lisp.H \
+ Constructor.H \
+ Database.H
if OA_BUILD_SMAN
OA_SMAN_TARGETS = all-sman all-clef
@@ -80,7 +82,7 @@ all-local: all-src
.PHONY: all-src all-io all-headers all-syntax $(OA_GRAPHICS_TARGETS)
all-src: all-lib all-utils all-driver all-lisp all-boot all-io all-syntax \
- all-interpsys all-algebra all-axiomsys all-share \
+ all-rt all-interpsys all-algebra all-axiomsys all-share \
all-asq all-input all-doc $(OA_SMAN_TARGETS) $(OA_GRAPHICS_TARGETS)
stamp-subdirs:
@@ -107,13 +109,16 @@ all-io: all-utils
all-syntax: all-io
cd syntax && $(MAKE) $(AM_MAKEFLAGS) $@
+all-rt: all-utils
+ cd rt && $(MAKE) $(AM_MAKEFLAGS) $@
+
all-clef: all-lib
cd clef && $(MAKE) $(AM_MAKEFLAGS) $@
all-sman: all-lib all-driver
cd sman && $(MAKE) $(AM_MAKEFLAGS) $@
-all-gui: all-driver all-io
+all-gui: all-driver all-io all-rt
cd gui && $(MAKE) $(AM_MAKEFLAGS)
all-hyper: all-lib all-io