aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordos-reis <gdr@axiomatics.org>2011-05-01 17:23:26 +0000
committerdos-reis <gdr@axiomatics.org>2011-05-01 17:23:26 +0000
commita2ae2e2de1538edb89b30cc811e5583248859bb2 (patch)
tree9923cd457c7be5646c250629d393a1e88d236329 /configure.ac
parentfd12ad84f465b3fab7d8e7bdc48febb940faa761 (diff)
downloadopen-axiom-a2ae2e2de1538edb89b30cc811e5583248859bb2.tar.gz
more cleanups
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 871a040b..bffcf30f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -96,6 +96,7 @@ OPENAXIOM_CHECK_IO
AM_CONDITIONAL([OA_BUILD_SMAN], [test $oa_use_sman = 1])
OPENAXIOM_CHECK_GRAPHICS
AM_CONDITIONAL([OA_BUILD_GRAPHICS], [test x$axiom_use_x = xyes])
+AM_CONDITIONAL([OA_BUILD_GUI], [test x$oa_has_qt = xyes])
OPENAXIOM_FFI_TYPE_TABLE
OPENAXIOM_GCL_BUILD_OPTIONS
@@ -124,9 +125,15 @@ OPENAXIOM_MAKEFILE([src/graph/view2D/Makefile])
OPENAXIOM_MAKEFILE([src/graph/view3D/Makefile])
OPENAXIOM_MAKEFILE([src/graph/viewAlone/Makefile])
OPENAXIOM_MAKEFILE([src/graph/viewman/Makefile])
+AC_CONFIG_FILES([src/gui/gui.pro])
AC_OUTPUT
+## Set up Makefile for QT-based gui
+if test x$oa_has_qt = xyes; then
+ (cd src/gui && $OA_QT_QMAKE -makefile gui.pro)
+fi
+
## Generate rules to extrad SPAD type definitions from pamphlets.
echo -n "extracting list of SPAD type definitions..."
egrep '<<(category|domain|package) .*>>=' \