aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordos-reis <gdr@axiomatics.org>2009-02-11 02:02:04 +0000
committerdos-reis <gdr@axiomatics.org>2009-02-11 02:02:04 +0000
commit79f5a19fba15519dfa7fe82f4dd1f0e91652cded (patch)
tree6e5aae96d498df4ea1c90c036bae75e96f5b6c98 /configure.ac
parent16ccc3d066711098e15ee8e678b249e0b9379990 (diff)
downloadopen-axiom-79f5a19fba15519dfa7fe82f4dd1f0e91652cded.tar.gz
* lib/openpty.c: #include <sys/ioctl.h>, <termios.h>, and
<libutil.h> where available.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5e28b888..dfcb440f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -459,7 +459,7 @@ AC_CHECK_DECLS([fork],
[#include <unistd.h>])
## Does this system have openpty or shall we emulate?
-AC_CHECK_HEADERS([pty.h util.h])
+AC_CHECK_HEADERS([sys/ioctl.h pty.h util.h libutil.h termios.h])
AC_CHECK_DECLS([openpty],[],[],
[#if HAVE_PTY_H
# include <pty.h>
@@ -467,6 +467,15 @@ AC_CHECK_DECLS([openpty],[],[],
#if HAVE_UTIL_H
# include <util.h>
#endif
+ #if HAVE_SYS_IOCTL_H
+ # include <sys/ioctl.h>
+ #endif
+ #if HAVE_TERMIOS_H
+ # include <termios.h>
+ #endif
+ #if HAVE_LIBTUIL_H
+ # include <libutil.h>
+ #endif
])
if test x"$ac_cv_have_decl_openpty" = xyes; then \
AC_SEARCH_LIBS([openpty],[util])