aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordos-reis <gdr@axiomatics.org>2009-09-16 06:20:06 +0000
committerdos-reis <gdr@axiomatics.org>2009-09-16 06:20:06 +0000
commit0c55ed614187758d4e0a670fc4f031d5f4ad7e4e (patch)
tree5764bcb9aba6369b1e82e5ddec37ac44ed58f7a4 /configure.ac
parentd982979c98f7a87c5ee8e5a84acc1bde09a53bf5 (diff)
downloadopen-axiom-0c55ed614187758d4e0a670fc4f031d5f4ad7e4e.tar.gz
2009-09-16 Kosta Oikonomou <ko@research.att.com>
Gabriel Dos Reis <gdr@cs.tamu.edu> * configure.ac.pamphlet: Don't insist on GNU C compiler if we don't use GCL. Check for nsl on Solaris boxes. * config/var-def.mk (oa_c_libs): New. src/ 2009-09-16 Kosta Oikonomou <ko@research.att.com> Gabriel Dos Reis <gdr@cs.tamu.edu> * graph/viewAlone/Makefile.in (viewAlone_LDADD): Include $(AXIOM_X11_LDFLAGS) and $(oa_c_libs). * graph/viewman/Makefile.in (viewman_LDADD): Likewise. * hyper/Makefile.in (htadd_LDADD): Likewise. * sman/Makefile.in (session_LDADD): Include $(oa_c_libs). (spadclient_LDADD): Likewise. (sman_LDADD): Likewise.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 17 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index d5e664a5..c5440b4d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,6 @@
sinclude(config/open-axiom.m4)
sinclude(config/aclocal.m4)
-AC_INIT([OpenAxiom], [1.4.0-2009-09-08],
+AC_INIT([OpenAxiom], [1.4.0-2009-09-16],
[open-axiom-bugs@lists.sf.net])
AC_CONFIG_AUX_DIR(config)
@@ -96,14 +96,6 @@ case $build in
;;
esac
-## Make sure the C compiler is from GCC
-AC_PROG_CC
-if test x$GCC != xyes; then
- AC_MSG_ERROR([We need a C compiler from GCC])
-fi
-axiom_cflags="-O2 -Wall -D_GNU_SOURCE"
-AC_SUBST(axiom_cflags)
-
## What is the extension of object files on this platform?
AC_OBJEXT
@@ -293,6 +285,21 @@ case $axiom_lisp_flavor,$target in
;;
esac
AC_SUBST(axiom_gcl_rsym_hack)
+
+
+## If we are using GCL as the base runtime system, then we do really need
+# a C compiler from GNU. Well, at least for the moment.
+case $axiom_lisp_flavor,$GCC in
+ gcl,yes)
+ axiom_cflags="-O2 -Wall -D_GNU_SOURCE"
+ ;;
+
+ gcl,*)
+ AC_MSG_ERROR([We need a GNU C compiler])
+ ;;
+esac
+AC_SUBST(axiom_cflags)
+
## Can we use dynamically linked libraries?
## Tentatively answer `yes' -- this is modern time.
oa_use_dynamic_lib=yes
@@ -430,6 +437,7 @@ case $host in
AC_SEARCH_LIBS([accept], [socket],
[axiom_c_runtime_extra="-lsocket"],
[AC_MSG_ERROR([socket library not found])])
+ AC_SEARCH_LIBS([gethostbyname], [nls])
;;
*) ;;
esac