aboutsummaryrefslogtreecommitdiff
path: root/npmPackages/inherits/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'npmPackages/inherits/default.nix')
-rw-r--r--npmPackages/inherits/default.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/npmPackages/inherits/default.nix b/npmPackages/inherits/default.nix
new file mode 100644
index 0000000..a03afdd
--- /dev/null
+++ b/npmPackages/inherits/default.nix
@@ -0,0 +1,23 @@
+{ fetchurl, buildNpmPackage, tap }:
+
+buildNpmPackage {
+ pname = "inherits";
+ version = "2.0.4";
+ src = fetchurl {
+ url = "https://github.com/isaacs/inherits/archive/v2.0.4.tar.gz";
+ sha256 = "0qbilb4qal96a5qi9a9pqw8gxjj72g4yxzjf7a1sphv3qbmr9ix6";
+ };
+
+ meta = {
+ description = "Browser-friendly inheritance fully compatible with standard node.js inherits()";
+ homepage = "";
+ license = "ISC";
+ };
+
+ npmInputs = [
+ tap
+ ];
+
+ jailbreak = true;
+}
+